Bug 46270 - X/virtual terminals fail on Radeon HD 6630M with KMS enabled, integrated graphics disabled
Summary: X/virtual terminals fail on Radeon HD 6630M with KMS enabled, integrated grap...
Status: RESOLVED DUPLICATE of bug 37528
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 18:57 UTC by Lawrence Hamblin
Modified: 2012-02-20 07:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (68.69 KB, text/plain)
2012-02-18 18:57 UTC, Lawrence Hamblin
no flags Details
Xorg.0.log (18.10 KB, text/plain)
2012-02-18 18:59 UTC, Lawrence Hamblin
no flags Details
kernel config (74.58 KB, text/plain)
2012-02-18 19:02 UTC, Lawrence Hamblin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lawrence Hamblin 2012-02-18 18:57:51 UTC
Created attachment 57256 [details]
dmesg

I have a Sony Vaio SE laptop with a Radeon HD 6630M (Turks) and Intel HD 3000 integrated graphics, and am running Gentoo Linux amd64 with kernel 3.2.1-r2 and xf86-video-ati 6.14.3.  I have the microcode installed and the Turks firmware built into the kernel, and KMS is enabled in grub.conf.

At boot, the kernel output on VT1 freezes after about two seconds.  However, I am still able to switch to other terminals, log in, and enter commands, but cannot see what I am doing due to the boot text being frozen on the screen.

dmesg shows radeon being loaded normally, but Xorg.0.log shows a "no devices detected" error.  This occurs both with no xorg.conf and with an xorg.conf that forces radeon to be loaded.  The Intel graphics were disabled in the kernel to be sure they weren't conflicting.  Furthermore, dmesg displays the following error:

"[Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work."

Adding the suggested parameter does not remove the error.
Comment 1 Lawrence Hamblin 2012-02-18 18:59:00 UTC
Created attachment 57257 [details]
Xorg.0.log
Comment 2 Lawrence Hamblin 2012-02-18 19:02:28 UTC
Created attachment 57258 [details]
kernel config
Comment 3 Alex Deucher 2012-02-19 18:27:20 UTC
You have a muxless system.  No physical displays are actually connected to the radeon card so it's not possible for it to drive the displays.  The X server needs a fair amount of work to properly support decoupled rendering and display.
Comment 4 Lawrence Hamblin 2012-02-20 05:55:30 UTC
I see--I thought that because the laptop has a physical switch that allows me to switch between graphics cards on the fly (in Windows) that I actually had a muxed system, but the display not being connected at all would explain why the radeon card isn't detected, even with intel disabled.

At any rate, does that make this a duplicate of bug 41265?  At one point, I had the same "Unable to locate a BIOS ROM" error as that user after updating my kernel from 3.0.6, but strangely, I think it was enabling vga-switcheroo in the kernel that caused it to disappear.
Comment 5 Alex Deucher 2012-02-20 07:17:54 UTC
(In reply to comment #4)
> At any rate, does that make this a duplicate of bug 41265?  At one point, I had the same "Unable to locate a BIOS ROM" error as that user after updating my
> kernel from 3.0.6, but strangely, I think it was enabling vga-switcheroo in the kernel that caused it to disappear.

The rom error was a temporary bug in the 3.3 branch.  It's been fixed now.  I don't think it's a duplicate of bug 41265 per se.  Both are related to non-MUXed configurations, but bug 41265 is about GPUs on a external docking station.

*** This bug has been marked as a duplicate of bug 37528 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.