Bug 46281 - Screen switching causes deadlock
Summary: Screen switching causes deadlock
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/Core (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 04:52 UTC by bugs.freedesktop.org.674292
Modified: 2016-11-28 04:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg log (430.34 KB, text/x-log)
2012-02-19 04:54 UTC, bugs.freedesktop.org.674292
no flags Details
xorg.conf (2.95 KB, text/plain)
2012-02-19 04:55 UTC, bugs.freedesktop.org.674292
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugs.freedesktop.org.674292 2012-02-19 04:52:45 UTC
I have a dual-screen setup with two separate screens handled by one nvidia geforce graphics card.

Bug gets triggered when starting playback (mplayer) on second screen in fullscreen mode, then quickly and repeatedly move the mouse from screen one to two and back. When disabling the hardware mouse cursor in xorg.conf, the problem goes away.

dmesg:

[28443.474348] NVRM: Xid (0000:01:00): 16, Head 00000001 Count 00243538


More details at:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/935912
Comment 1 bugs.freedesktop.org.674292 2012-02-19 04:54:06 UTC
Created attachment 57274 [details]
xorg log
Comment 2 bugs.freedesktop.org.674292 2012-02-19 04:55:07 UTC
Created attachment 57275 [details]
xorg.conf
Comment 3 bugs.freedesktop.org.674292 2012-02-19 04:55:32 UTC
ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CurrentDmesg:
 Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Keine Berechtigung
 dmesg: write failed: Datenübergabe unterbrochen (broken pipe)
Date: Sun Feb 19 03:17:15 2012
DistUpgraded: Log time: 2012-02-12 12:51:46.485634
DistroCodename: precise
DistroVariant: ubuntu
EcryptfsInUse: Yes
MachineType: Gigabyte Technology Co., Ltd. P55-USB3
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 LANGUAGE=de:en
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-16-generic root=/dev/mapper/hostnamevg-hostnameroot ro ipv6.disable=1 ip=dhcp ISCSI_INITIATOR=iqn.1993-08.org.debian:01:95384da15332 ISCSI_TARGET_NAME=iqn.mstier.de:desktop64.img ISCSI_TARGET_IP=192.168.0.4 ISCSI_TARGET_PORT=3260
SourcePackage: xserver-xorg-input-evdev
UpgradeStatus: Upgraded to precise on 2012-02-12 (6 days ago)
dmi.bios.date: 02/11/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: P55-USB3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd02/11/2010:svnGigabyteTechnologyCo.,Ltd.:pnP55-USB3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP55-USB3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P55-USB3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2
Comment 4 bugs.freedesktop.org.674292 2012-02-19 04:56:36 UTC
the attached xorg.conf has hwcursor set to false, but must be set to true in order to trigger the bug.
Comment 5 Peter Hutterer 2012-02-19 14:56:22 UTC
I'm sure there's a bug file for this already but I couldn't find it. Either way, it's a longer-standing issue that hasn't been tracked down yet. It's in the server though.
Comment 6 bugs.freedesktop.org.674292 2012-02-20 12:19:24 UTC
Is there anything I can do to help?
Comment 7 Peter Hutterer 2012-02-20 19:28:02 UTC
(In reply to comment #6)
> Is there anything I can do to help?

a reliable reproducer. unfortunately, it seems to be a race condition and I haven't managed to reliably trigger it yet.
Comment 8 bugs.freedesktop.org.674292 2012-02-21 11:59:25 UTC
It is *very* reliable here.
Comment 9 Peter Hutterer 2012-02-21 20:31:21 UTC
once it hangs, attach gdb and see what causes the loop. Is it stuck in a single function or does it actually still process events?
Comment 10 bugs.freedesktop.org.674292 2012-02-22 12:38:34 UTC
The culprit is "DISPLAY=:0.1 xrandr -r 24".

It always happens after switching the refresh rate of the second screen using xrandr.
Comment 11 bugs.freedesktop.org.674292 2012-02-23 14:48:45 UTC
Forwarded to nvidia.

It gets stuck somewhere within the nvidia driver.
Comment 12 Peter Hutterer 2016-11-28 04:39:50 UTC
This is a mass change of bugs. Bugs assigned to me that haven't been updated in the last 3 years are closed as WONTFIX, because, well, let's at least be honest about it.

Please do not re-open unless you have a really good reason to do so (e.g. you're fixing it yourself). If it hasn't been fixed in the last 3 years, it probably won't be fixed anytime soon either. Sorry.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.