Bug 47573 - edge xserver-xorg-video-ati. Text corruption in desktop environments.
Summary: edge xserver-xorg-video-ati. Text corruption in desktop environments.
Status: RESOLVED DUPLICATE of bug 47266
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-20 05:28 UTC by piroxiline
Modified: 2012-03-21 15:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot compilation that showing bug. (290.87 KB, image/png)
2012-03-20 05:28 UTC, piroxiline
no flags Details
full dmesg output (55.44 KB, text/plain)
2012-03-20 07:06 UTC, piroxiline
no flags Details
Xorg log file (121.33 KB, text/plain)
2012-03-20 07:08 UTC, piroxiline
no flags Details
Xorg.0.log (121.33 KB, text/x-log)
2012-03-20 07:34 UTC, piroxiline
no flags Details
dmesg.txt (55.44 KB, text/plain)
2012-03-20 07:34 UTC, piroxiline
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description piroxiline 2012-03-20 05:28:47 UTC
Created attachment 58739 [details]
Screenshot compilation that showing bug.

updating xserver-xorg-video-ati from stable version to the edge caused every other time text rendering corruption in desktop environments (gnome, xfce). But problem appears in places: in the taskbar, terminal emulators, file manager, pop-up text messages, drop-down menus, Chromium address field (in Firefox everything works properly) and etc.

xserver-xorg-video-ati 1:6.14.99+git20120308.b5cf9bd6-0ubuntu0sarvatt
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV630 [Radeon HD 2600 Series]
Ubuntu 12.04 Precise (bug appears also back in 11.10 Oneiric)
Comment 1 Alex Deucher 2012-03-20 06:46:39 UTC
Please attach your xorg log and dmesg output.  Also, any chance you could bisect?
Comment 2 piroxiline 2012-03-20 07:06:44 UTC
Created attachment 58750 [details]
full dmesg output
Comment 3 piroxiline 2012-03-20 07:08:19 UTC
Created attachment 58751 [details]
Xorg log file
Comment 4 piroxiline 2012-03-20 07:34:02 UTC
On 03/20/2012 03:46 PM, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=47573
>
> Alex Deucher<agd5f@yahoo.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>           AssignedTo|eich@pdx.freedesktop.org    |xorg-driver-ati@lists.x.org
>            Component|Driver/radeonhd             |Driver/Radeon
>
> --- Comment #1 from Alex Deucher<agd5f@yahoo.com>  2012-03-20 06:46:39 PDT ---
> Please attach your xorg log and dmesg output.  Also, any chance you could
> bisect?
>
I attach xorg log and dmesg output to the bug report. The same attached 
to e-mail.
I understand what do you mean about "bisect", but it takes a time to 
learn how to use git and bisect and testing driver.
Thank you for rapid respond.
Comment 5 piroxiline 2012-03-20 07:34:02 UTC
Created attachment 58753 [details]
Xorg.0.log
Comment 6 piroxiline 2012-03-20 07:34:02 UTC
Created attachment 58754 [details]
dmesg.txt
Comment 7 Ernst Sjöstrand 2012-03-21 15:47:55 UTC
Looks like the exact same thing to me, I see lots of output like that also.

*** This bug has been marked as a duplicate of bug 47266 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.