Bug 48001 - Glitches with "EAXPixmaps" "on" (default) and cairo-xcb
Summary: Glitches with "EAXPixmaps" "on" (default) and cairo-xcb
Status: RESOLVED DUPLICATE of bug 47266
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-28 05:56 UTC by Mathias Anselmann
Modified: 2012-03-28 06:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Anselmann 2012-03-28 05:56:35 UTC
Hello,
I'm using "ati-dri 8.0.2" and I encounter artifacts like this:
http://i.imgur.com/2A2Kw.jpg
when using cairo (compiled with xcb-support) and the default radeon settings.
If I disable "EAXPixmaps" support in my xorg.conf everything is fine.
I realized the glitches in firefox and awesome window manager (in the top panel).

This was also with cairo-xcb 1.10 (and ati-dri 7.11) an issue for me but since yesterday's update to 1.12 the glitches come more frequently (browsing is more or less impossible with enabled EAXPixmaps support).
Since I don't know whether this is cairo's or radeon's fault I'm opening a bug report here as well as in the cairo bug tracker.
Comment 1 Alex Deucher 2012-03-28 06:05:45 UTC

*** This bug has been marked as a duplicate of bug 47266 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.