Bug 48286 - UpdateManager API change breaks get-distro-upgrade.py
Summary: UpdateManager API change breaks get-distro-upgrade.py
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-apt (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 02:20 UTC by Henry-Nicolas Tourneur
Modified: 2018-08-21 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henry-Nicolas Tourneur 2012-04-04 02:20:21 UTC
Hello,

The API of update-manager changed so it's not possible anymore to import the MetaReleaseCore object since it doesn't exist.

The documentation of the new API is available here: 
http://update-manager.alioth.debian.org/doc/current/

This affects both APT backends so it would be great if you could update this code so it can use the new API update-manager exposes.

Thanks and best regards,
Comment 1 Richard Hughes 2018-08-21 15:52:55 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.