Bug 4886 - Xdmx has problem with visuals with backend servers on machines of opposite endianess
Summary: Xdmx has problem with visuals with backend servers on machines of opposite en...
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/dmx (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: dmx-bugs
QA Contact: Xorg Project Team
URL:
Whiteboard: 2011BRB_Reviewed
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-25 19:28 UTC by Stephen P. Becker
Modified: 2018-12-13 18:26 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Stephen P. Becker 2005-10-25 19:28:58 UTC
While attempting to use Xdmx to spread my display out between a x86 and a mips
(big endian SGI) box using xinerama, there are no visuals that match, and
therefore results in a failure.  See http://dev.gentoo.org/~geoman/dmxlog.txt
for the output log.  I believe the problem is due to the endian difference
between these two machines.  They appear to be using the same visual by default,
but they are reversed, eg:

(II) dmx[o0/hellfire:1]: 0x21 TrueColor   24b 8b/rgb 256 0xff0000 0xff00 0x00ff *
vs.
(II) dmx[o1/pimpdaddy:0]: 0x22 TrueColor   24b 8b/rgb 256 0x00ff 0xff00 0xff0000 *

I talked with ajax on irc, and he seems to think it shouldn't be too much of a
problem to add tracking of byteswapping on the fly per backend display.
Comment 1 Daniel Stone 2007-02-27 01:28:33 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 2 GitLab Migration User 2018-12-13 18:26:52 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/112.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.