Bug 49200 - Cursor moves on tap
Summary: Cursor moves on tap
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/synaptics (show other bugs)
Version: git
Hardware: Other All
: medium enhancement
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-26 17:07 UTC by Peter Hutterer
Modified: 2015-08-12 06:07 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Peter Hutterer 2012-04-26 17:07:27 UTC
From: https://bugzilla.redhat.com/show_bug.cgi?id=816391

The cursor still moves on tap if the movement is outside the defined hysteresis. Reproducible by tapping on an angle so that movement is generated within the first few events.

Fixing this is tricky. The movement must be less than MaxTapMove (we want tap after all) and more than the hysteresis. Simple fix is to force deltas to 0 in TS_1 state but that delays any normal movement by MaxTapTime. In the default time, this is noticeable and bad user experience.

Possible options could be:
- discarding the first one or two motions
- some second time for tapping that defines a medium range to reduce the delay
- workaround: increasing the hysteresis values

Options above are untested and need to be checked for user experience changes.
Comment 1 Luke Hutchison 2014-05-20 07:47:03 UTC
This is still a problem with xorg-x11-drv-synaptics-1.7.1-5.fc20.x86_64, making the touchpad on a Dell XPS 15 Touch almost unusable. Tapping/clicking with the side of your thumb is particularly problematic, because as your thumb goes down, the touch "blob" (contact area of the thumb on the touchpad) changes dramatically in size and shape, dragging the centroid strongly in one direction.

Can the size or pressure of the touch point be used to determine if a drag is being performed? If the size or pressure of the touch point is changing dramatically, the pointer should not move even though the centroid of the touch point is moving.
Comment 2 Peter Hutterer 2015-08-12 06:07:04 UTC
feature request has been open for three years, going to call this a WONTFIX.
at this point a fix like that is going to end up in libinput anyway rather than synaptics.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.