Bug 4925 - Wrongly displayed watermark makes reading PDF files impossible on canon documents
Summary: Wrongly displayed watermark makes reading PDF files impossible on canon docum...
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Kristian Høgsberg
QA Contact:
URL: http://www.canon.ca/english/index-cus...
Whiteboard:
Keywords:
Depends on: 12661
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-29 09:22 UTC by ruben
Modified: 2018-08-20 22:07 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
A UK royalmail online stamp which doesn't print correctly (48.55 KB, application/pdf)
2008-06-11 02:20 UTC, Paul Hirst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ruben 2005-10-29 09:22:06 UTC
A very ugly watermark (some copy protection) is displayed on top of all text,
making the reading of this PDF impossible. Adobe acrobat does get it right though.

The PDF can be obtained here:

 1. http://www.canon.ca/english/index-customersupport.asp?pid=344
 2. Choose the documentation link
 3. Get the Camera User Guide from the bottom of the page (PSS2ISCUG-EN.pdf)
Comment 1 Sergej Kotliar 2006-01-29 11:34:41 UTC
I believe this has to do with poppler currently not supporting transparency.

I'm not too sure though, so I wont close this as duplicate just yet and let the
devs look at it...
Comment 2 Nickolay V. Shmyrev 2006-04-22 20:43:14 UTC
For an example PDF, go to:
http://consumer.usa.canon.com/ir/controller?act=SupportDetailAct&fcategoryid=215&modelid=12929

Click on "Product / Software Manuals"

Download the "EOS 30D Introduction Manual (PDF, 6.15 MB)"

All pages show "COPY", instead of the content of the file, which is the product
manual with a "COPY" watermark on each page.  I'll attach the file if attaching
files is possible here.

Similar evince bug 338445
Comment 3 bertrand.haut 2006-10-23 02:26:39 UTC
With my current installed kpdf (0.5.5) using libpoppler1 (0.5.1-0ubuntu7), I'm 
able to read the two examples seeing the COPY and the text content. Maybe this 
bug should be closed
Comment 4 Jan Janssens 2006-12-24 07:20:24 UTC
This is a bug.

The "COPY" text is rendered correctly, but since it is a "Print Only Watermark",
it should only be printed, not displayed when viewing the PDF on screen.

Adobe Acrobat does not show the COPY text, only when choosing Print Preview or
actually printing it.
Comment 5 Ken Arromdee 2007-11-21 20:20:05 UTC
This bug affects the Marvel Comics DVD-ROMs that have been published for the last year or two.  If you use Adobe Acrobat 6 or greater each page has a big "MARVEL" plastered across it when printed, but not on the screen.  However, all known Linux PDF reading programs show the watermark even on the screen.
Comment 6 Brad Hards 2007-12-02 22:51:48 UTC
OK, there are two different problems here.

The original problem was an opaque COPY watermark instead of the text. That problem has now been fixed (update to poppler 0.6 if you use evince and are still seeing this).

The problem identified in comment #4 and #5 is related to Optional Content implementation. This is the relevant part of the PSSISCUG-EN.pdf document:
779 0 obj<</Pages 753 0 R/Type/Catalog/OpenAction 780 0 R/PageLabels 751 0 R/Metadata 775 0 R/OCProperties<</D<</Order[]/AS[<</OCGs[782 0 R]/Category[/View]/Event/View>><</OCGs[782 0 R]/Category[/Print]/Event/Print>><</OCGs[782 0 R]/Category[/Export]/Event/Export>>]/ON[782 0 R]/RBGroups[]>>/OCGs[782 0 R]>>>>
endobj
782 0 obj<</Type/OCG/Name(Í2ZÒ°yLÏø)/Usage<</Export<</ExportState/ON>>/Print<</PrintState/ON>>/View<</ViewState/OFF>>/PageElement<</Subtype/FG>>>>>>
endobj

That might be quite hard to implement in poppler without an API change...
Comment 7 Paul Hirst 2008-06-11 02:20:52 UTC
Created attachment 17053 [details]
A UK royalmail online stamp which doesn't print correctly

My experience is the other way around.

The UK postal service allow you to print stamps online (they come with a unique 2d barcode). The service is web based and provides you with a PDF to print and attach to your envelope. The on screen rendering contains a 'watermark' across the whole image which is supposed to be absent once printed. Using Evince the 'watermark' is present on the printed version rendering it useless.

The watermark in this case is the word 'Sample' written in large letters diagonally across the middle and a box containing 'Sample will not appear when printed'. Unfortunately when using Evince this is a lie!

I have reported this to Ubuntu which is what led me here.
https://bugs.launchpad.net/bugs/238817

This attachment is an example as produced at www.royalmail.com
Comment 8 Carlos Garcia Campos 2009-11-18 08:22:01 UTC
This bug is fixed since poppler 0.11. Feel free to reopen it if the problem is still present for you with current poppler
Comment 9 Michael Gilbert 2010-08-07 20:17:01 UTC
i can still reproduce this issue with poppler 0.12.
Comment 10 dulsi2000 2011-10-31 06:55:37 UTC
I have also seen the problem with The Incredible Hulk: The Complete Collection.
Comment 11 GitLab Migration User 2018-08-20 22:07:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/203.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.