Bug 50683 - Black screen with "AutoAddDevices" "Off"
Summary: Black screen with "AutoAddDevices" "Off"
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard: 2012BRB_Reviewed
Keywords: regression
Depends on:
Blocks: xserver-1.12
  Show dependency treegraph
 
Reported: 2012-06-04 07:48 UTC by Alex Henrie
Modified: 2012-07-03 16:35 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.51 KB, text/plain)
2012-06-04 07:48 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.11.3 (20.05 KB, text/plain)
2012-06-04 07:49 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.12.2 (15.22 KB, text/plain)
2012-06-04 07:50 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.12.2-nouveau (24.56 KB, text/plain)
2012-06-13 08:29 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.12.2-nouveau-nomodeset (80.39 KB, text/plain)
2012-06-13 08:30 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.12.2-withxorgconf-nouveau (15.73 KB, text/plain)
2012-06-13 08:31 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.12.2-withxorgconf-nouveau-nomodeset (67.12 KB, text/plain)
2012-06-13 08:32 UTC, Alex Henrie
no flags Details
Xorg.0.log-1.12.2-withxorgconf-nvidia-kbd1.6.1 (15.11 KB, text/plain)
2012-06-15 08:12 UTC, Alex Henrie
no flags Details
startx-stderr (1.26 KB, text/plain)
2012-07-02 08:49 UTC, Alex Henrie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Henrie 2012-06-04 07:48:37 UTC
Created attachment 62512 [details]
xorg.conf

I am running Lubuntu 12.04 with an Nvidia GF106GL [Quadro 2000] (rev a1) and the proprietary nvidia driver. I use an xorg.conf generated by the NVIDIA X Server Settings tool with one line added:

    Option         "AutoAddDevices" "Off"

I also installed the package xserver-xorg-input-kbd to make the keyboard work with this xorg.conf.

After updating from Xorg server 1.11.3 to 1.12.2 by adding the xorg-edgers repository, I get a black screen on startup. Ctrl+Alt+F1 does not work either.

For reference, I installed Xorg server 1.12.2 with the commands:

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade
Comment 1 Alex Henrie 2012-06-04 07:49:40 UTC
Created attachment 62513 [details]
Xorg.0.log-1.11.3

Xorg.0.log before update
Comment 2 Alex Henrie 2012-06-04 07:50:07 UTC
Created attachment 62514 [details]
Xorg.0.log-1.12.2

Xorg.0.log after update
Comment 3 Jeremy Huddleston Sequoia 2012-06-12 04:19:39 UTC
Does this only occur as a result of AutoAddDevices?

Please make sure you attach logs with the correct mime settings...
Comment 4 Alex Henrie 2012-06-12 07:06:53 UTC
Yes. The exact same xorg.conf without "AutoAddDevices" "Off" works perfectly.
Comment 5 Jeremy Huddleston Sequoia 2012-06-12 09:25:22 UTC
This smells like an nVidia issue.  Are you sure you used the exact same video driver versions with both server versions?  Compare this output from the two logs.  1.11.3 shows "Assigned Display Device: DFP-1" whereas 1.12.2 shows no such line.  My guess is that this is an nVidia driver bug.  Please reopen if you can reproduce with nouveau or nv.


[     4.351] (--) NVIDIA(1): Connected display device(s) on Quadro 2000D at PCI:1:0:0
[     4.351] (--) NVIDIA(1):     DELL U2412M (DFP-0)
[     4.351] (--) NVIDIA(1):     DELL U2412M (DFP-1)
[     4.351] (--) NVIDIA(1): DELL U2412M (DFP-0): 330.0 MHz maximum pixel clock
[     4.351] (--) NVIDIA(1): DELL U2412M (DFP-0): Internal Dual Link TMDS
[     4.351] (--) NVIDIA(1): DELL U2412M (DFP-1): 330.0 MHz maximum pixel clock
[     4.351] (--) NVIDIA(1): DELL U2412M (DFP-1): Internal Dual Link TMDS
[     4.351] (II) NVIDIA(1): Display Device found referenced in MetaMode: DFP-1
[     4.351] (**) NVIDIA(1): Using HorizSync/VertRefresh ranges from the EDID for display
[     4.351] (**) NVIDIA(1):     device DELL U2412M (DFP-1) (Using EDID frequencies has
[     4.351] (**) NVIDIA(1):     been enabled on all display devices.)
[     4.370] (II) NVIDIA(1): Assigned Display Device: DFP-1
[     4.370] (II) NVIDIA(1): Validated modes:
[     4.370] (II) NVIDIA(1):     "DFP-1:nvidia-auto-select+0+0"


[     4.317] (--) NVIDIA(1): Valid display device(s) on Quadro 2000D at PCI:1:0:0
[     4.317] (--) NVIDIA(1):     CRT-0
[     4.317] (--) NVIDIA(1):     CRT-1
[     4.317] (--) NVIDIA(1):     DELL U2412M (DFP-0) (connected)
[     4.317] (--) NVIDIA(1):     DELL U2412M (DFP-1) (connected)
[     4.317] (--) NVIDIA(1): CRT-0: 400.0 MHz maximum pixel clock
[     4.317] (--) NVIDIA(1): CRT-1: 400.0 MHz maximum pixel clock
[     4.317] (--) NVIDIA(1): DELL U2412M (DFP-0): 330.0 MHz maximum pixel clock
[     4.317] (--) NVIDIA(1): DELL U2412M (DFP-0): Internal Dual Link TMDS
[     4.317] (--) NVIDIA(1): DELL U2412M (DFP-1): 330.0 MHz maximum pixel clock
[     4.317] (--) NVIDIA(1): DELL U2412M (DFP-1): Internal Dual Link TMDS
[     4.317] (**) NVIDIA(1): Using HorizSync/VertRefresh ranges from the EDID for display
[     4.317] (**) NVIDIA(1):     device DELL U2412M (DFP-1) (Using EDID frequencies has
[     4.317] (**) NVIDIA(1):     been enabled on all display devices.)
[     4.317] (II) NVIDIA(1): Validated modes:
[     4.317] (II) NVIDIA(1):     "DFP-1:nvidia-auto-select+0+0"
Comment 6 Alex Henrie 2012-06-13 08:28:12 UTC
I can reproduce with nouveau as well, although nouveau has other problems.
Comment 7 Alex Henrie 2012-06-13 08:29:09 UTC
Created attachment 62969 [details]
Xorg.0.log-1.12.2-nouveau

Xorg 1.12.2 (no xorg.conf) + nouveau = visual artifacts, unusable screen
Comment 8 Alex Henrie 2012-06-13 08:30:20 UTC
Created attachment 62970 [details]
Xorg.0.log-1.12.2-nouveau-nomodeset

Xorg 1.12.2 (no xorg.conf) + nouveau + nomodeset boot option = usable screen but looks stretched
Comment 9 Alex Henrie 2012-06-13 08:31:42 UTC
Created attachment 62971 [details]
Xorg.0.log-1.12.2-withxorgconf-nouveau

Xorg 1.12.2 + xorg.conf from comment 0 + nouveau = visual artifacts, unusable screen
Comment 10 Alex Henrie 2012-06-13 08:32:30 UTC
Created attachment 62972 [details]
Xorg.0.log-1.12.2-withxorgconf-nouveau-nomodeset

Xorg 1.12.2 + xorg.conf from comment 0 + nouveau + nomodeset boot option = black screen (same as nvidia driver)
Comment 11 Peter Hutterer 2012-06-14 19:36:14 UTC
This looks very much like the keyboard driver is busted. Can you give the upstream driver a try?
Comment 12 Alex Henrie 2012-06-15 08:12:31 UTC
Created attachment 63076 [details]
Xorg.0.log-1.12.2-withxorgconf-nvidia-kbd1.6.1

Okay, I installed kbd 1.6.1 (up from the previously installed version 1.6.0) with the commands:

    wget ftp://mirror.csclub.uwaterloo.ca/x.org/X11R7.7/src/driver/xf86-input-keyboard-1.6.1.tar.bz2 --output-document=- | tar -xj
    cd xf86-input-keyboard-1.6.1
    ./configure
    make
    sudo make install

I'm still getting a black screen.
Comment 13 Peter Hutterer 2012-07-01 16:12:14 UTC
boot into runlevel 3, then start X manually from the tty - do you see any error messages?
Comment 14 Alex Henrie 2012-07-02 08:49:44 UTC
Created attachment 63704 [details]
startx-stderr

I booted Ubuntu into recovery mode, enabled networking (to make it remount the filesystem as read/write), dropped to a root shell, and ran "startx 2> startx-stderr". After the screen went black, I waited a couple of seconds and pressed Alt+PrtScn+K, then Ctrl+Alt+F1, then Ctrl+C, which returned me to the shell. The resulting startx-stderr file is attached. The most interesting line is:

/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/input/kbd_drv.so: undefined symbol: xf86IsPc98
Comment 15 Peter Hutterer 2012-07-02 21:42:20 UTC
checked the previous log again, you're still on 1.6.0, which is why you see that unresolved symbol (it has been removed since).

[     3.556] (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
[     3.556] (II) Module kbd: vendor="X.Org Foundation"
[     3.556] 	compiled for 1.11.3, module version = 1.6.0
[     3.556] 	Module class: X.Org XInput Driver
[     3.556] 	ABI class: X.Org XInput driver, version 16.0

run ./configure --prefix=/usr, I guess you installed the driver into /usr/local and the server still doesn't load it. make sure it gets installed as /usr/lib/xorg/modules/input/kbd_drv.so.
Comment 16 Alex Henrie 2012-07-03 07:29:36 UTC
Thanks, that did the trick! And sorry for the trouble. It looks like xserver-xorg-input-kbd is being upgraded to 1.6.1 in the next version of Ubuntu, so the mismatch between Xorg and its keyboard driver should be going away.

See http://packages.ubuntu.com/quantal/x11/xserver-xorg-input-kbd
Comment 17 Peter Hutterer 2012-07-03 15:02:26 UTC
Thanks for verifying. I recommend pushing the Ubuntu guys to update to 1.6.1 in the current release as well - anyone running 1.6.0 will run into this issue.
Comment 18 Bryce Harrington 2012-07-03 16:35:30 UTC
As per the original bug report this occurs with the xorg-edgers repository only, not the release.

"After updating from Xorg server 1.11.3 to 1.12.2 by adding the xorg-edgers repository, I get a black screen on startup."

Looks like Sarvatt updated the -keyboard in edgers to 1:1.6.1+git20120703.dd6f110c-0ubuntu0sarvatt~precise about an hour ago, so assuming all should be well now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.