Bug 51533 - There is no smooth scrolling when using the EmulateWheel feature
Summary: There is no smooth scrolling when using the EmulateWheel feature
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: unspecified
Hardware: Other All
: medium enhancement
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 13:12 UTC by Léo Gillot-Lamure
Modified: 2018-08-10 20:54 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Patch that applies against 2.9.0 (8.56 KB, text/plain)
2015-06-17 09:32 UTC, Chow Loong Jin
no flags Details
Patch against 2.9.2 (8.28 KB, patch)
2016-04-27 18:49 UTC, main.haarp
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Léo Gillot-Lamure 2012-06-28 13:12:43 UTC
On a machine with a touchpad (using, i guess, synaptics driver), scrolling by sliding the finger at the right of the touchpad produces smooth scrolling (that is, if i only do a tiny movement i only get a scrolling of a few pixels instead of a whole line) in softwares that support it like nautilus.

One would expect that the option EmulateWheel of the evdev driver (used on a trackball without scrollwheel) produces the same effect, since it's all about scrolling being produces by an analogical source instead of being produced by buttons 4 and 5.
Comment 1 Peter Hutterer 2012-06-28 23:04:43 UTC
yes, that would be the right thing to do here and patches are welcome.

Note that you could either add a separate scroll axis (difficult, if enabled at runtime) or scale the inertia setting into the existing scroll axes' increment. since we currently can't change the increment on a scroll class at runtime, the latter is the better approach.
Comment 2 Chow Loong Jin 2015-06-17 09:32:23 UTC
Created attachment 116551 [details]
Patch that applies against 2.9.0

I dug this patch out from a mailing list post a while back and forward-ported it to 2.9.0. It works, at least on 2.9.0.

I tried applying it on git master, but have been unable to get it working correctly there.
Comment 3 main.haarp 2016-04-27 18:49:34 UTC
Created attachment 123310 [details] [review]
Patch against 2.9.2

Yes, back in 2014, Max tried getting this patch upstream, but there was no response. I'd love to see this in the driver, as trackpoint smooth scrolling is really pleasant.

I've ported the patch to v2.9.2. I didn't bother with git, because I'm no developer and barely know what I'm doing anyway :P
Comment 4 main.haarp 2016-10-01 11:12:17 UTC
I tried tweaking the patch for v2.10.3, but I know too little of the context to deal with patches like this: https://cgit.freedesktop.org/xorg/driver/xf86-input-evdev/commit/?id=593bbc6390aa6f9feec0e2b081e1bfe6ab03595a :(

Unless someone more knowledgeable comes along, I guess this stops the smooth-scrolling adventures.
Comment 5 Léo Gillot-Lamure 2016-10-01 12:20:52 UTC
As for me, I get the functionality by using the libinput driver. All I can do regarding buttons mapping and stuff is possible as well and libinput is the recommended driver nowadays, isn't it ?

So problem is workarounded :).
Comment 6 GitLab Migration User 2018-08-10 20:54:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-input-evdev/issues/2.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.