Bug 52132 - [SNB IVB, regression] Openarena abort after setup resolution, on mesa master and 8.0 branch
[SNB IVB, regression] Openarena abort after setup resolution, on mesa master ...
Status: VERIFIED WORKSFORME
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
All Linux (All)
: high major
Assigned To: Ian Romanick
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 03:42 UTC by cc
Modified: 2014-08-04 04:44 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cc 2012-07-16 03:42:31 UTC
Environment:
------------
Guest OS Type : Linux
Hardware: Ivybriage


Libdrm:		(master)libdrm-2.4.37-6-22574aa887efa879519328acc09cb01d03374bf4
Mesa:		(8.0)8d0fd5854628e4a67e7e75fb8bc9a8d2ff1a71ae
Xserver:		(server-1.12-branch)xorg-server-1.12.1
Xf86_video_intel:		(master)2.19.0-474-g0e397e4a1dc23ed07089c967612d705584f3b376
Cairo:		(master)dbc0efad7e565558a3abf7f69d7675efddc4688d
Libva:		(master)32a8cbd8bb1652473e49f933545b6ace716fd5dd
Libva_intel_driver:		(master)b70b40930fa29304d360389ec9c4c9b1a5661216

Kernel(Linux 3.4)
Kernel: (master)76e10d158efb6d4516018846f60c2ab5501900bc


Bug detailed description:
--------------------------
After setup the resolution, the game will abort. On the terminal we can find some error info as follows:

unknown blend mode 'gl_one_minus_dst_color' in shader 'menuback_blueish', substituting GL_ONE
Received signal 11, exiting...
----- CL_Shutdown -----

Additionally, I also tried the commit'Mesa  (8.0)3d657b14b4cab98a2945904823e78cd8950944f4' and, did not find this issue, So, It is a regression.


Reproduce steps:
----------------
1.xinit&
2.openarena
3.select: setup -> system -> resolution -> 1366x768 or 1024x768 -> accept
Comment 1 cc 2012-07-16 06:14:13 UTC
This issue also exist on master.

Mesa: (master)33202b4876a88b6f54ca7022eadd2875a2d3508a
Comment 2 cc 2012-07-16 07:30:11 UTC
The Sandybridge have the same issue.
Comment 3 Ian Romanick 2012-07-16 15:56:22 UTC
Bisect on 8.0 branch?
Comment 4 Eric Anholt 2012-08-02 21:20:30 UTC
Works for me.
Comment 5 cc 2012-08-03 02:03:52 UTC
OKay, I checked it with latest commit on branch 8.0 and found this issue had fixed.
the commit info as follows:
commit bb36936d12aa5f8ed3546b47fb8511c23f1f7fb5
Author:     Brian Paul <brianp@vmware.com>
AuthorDate: Mon Jul 16 14:14:07 2012 -0600
Commit:     Ian Romanick <ian.d.romanick@intel.com>
CommitDate: Tue Jul 31 12:25:50 2012 -0700

    st/egl: fix uninitialized pointer bug
    
    If no format is matched in the loop the value of xconf was undefined.
    
    NOTE: This is a candidate for the 8.0 branch.
    (cherry picked from commit fe2a7b7e7fca599659b1d248e160d480f2b92ba2)
Comment 6 Kenneth Graunke 2012-08-05 01:14:13 UTC
This works for me, apparently worked for Eric, and according to the final comment, now works for the reporter.  Marking as "WORKSFORME" since there was never an actual "fix" pinpointed.