Bug 52719 - EXDATE ignored by SonyEricsson t700 calendar
Summary: EXDATE ignored by SonyEricsson t700 calendar
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 13:44 UTC by SyncEvolution Community
Modified: 2018-10-13 12:43 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
ics exported by evo with uid (deleted)
2010-12-15 06:15 UTC, SyncEvolution Community
Details
ics exported by t700 missing the uid (deleted)
2010-12-15 06:16 UTC, SyncEvolution Community
Details

Description Patrick Ohly 2012-07-29 18:36:00 UTC


---- Reported by karlrt@gmx.net 2010-11-17 13:44:39 +0000 ----

BUILD IMAGE(X.X.XX.X.XXXXXXXX.X - (e.g.: meego-netbook-ia32-1.0.90.0.20100831.1)):         

HARDWARE MODEL (on what HW this bug is uncovered): T700

BUG DETAILED DESCRIPTIONS
===========================================================

EXACT STEPS LEADING TO PROBLEM:
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
===========================================================
1.create reoccuring event (due to https://bugs.meego.com/show_bug.cgi?id=10092 without the "until" option, either indefinitly or repeated n times) with evolution or mobile phone
2.add exeption to one of the events (only works in evolution)
3.sync

EXPECTED OUTCOME:
===================

SE should handle the event correctly: at date of exeption, there should be no event in the calendar

ACTUAL OUTCOME:
===================

SE ignores the EXDATE values in the ics file: the event shows up at all dates, even on the specified exeptions

USER IMPACT:
===================

usability to view a calendar on SE gets very low, lots of events are reoccuring, and the exeptions are often the most important part of it.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
=====================================

always

EXTRA SOFTWARE INSTALLED:
============================

OTHER COMMENTS:
===================

The only solution i could think of was to split up the n-repeated event into n different events so SE could view them correctly.



---- Additional Comments From patrick.ohly@intel.com 2010-11-18 05:28:05 +0000 ----

(In reply to comment #0)
> The only solution i could think of was to split up the n-repeated event into n
> different events so SE could view them correctly.  

That's nasty and would make it very hard to do two-way synchronization. Is two-way synchronization something that you are willing to give up in return for having working exceptions?

Does the phone have UID support? We send the UID property to it. Does that value come back? Perhaps that could be used to re-combine separate events back into one.



---- Additional Comments From patrick.ohly@intel.com 2010-12-15 02:14:11 +0000 ----

Please see my previous comment for some open questions.



---- Additional Comments From karlrt@gmx.net 2010-12-15 02:21:06 +0000 ----

> two-way synchronization something that you are willing to give up in return for
> having working exceptions?

Oh, i need two-way sync, a lot of times i get infos of events without my pc on!

> Does the phone have UID support? We send the UID property to it. Does that
> value come back? Perhaps that could be used to re-combine separate events back
> into one.  

I will investigate in the UID thing, that could be a solution!



---- Additional Comments From karlrt@gmx.net 2010-12-15 06:09:36 +0000 ----

does not look good for UID, i add as attachment one simple event, once saved as ics from evolution, and once sent as ics via bluetooth from the phone. The exported ics from the phone misses the UID tag. (but this might also be due to an "export" function)

How can i test it in a better way?



---- Additional Comments From karlrt@gmx.net 2010-12-15 06:15:27 +0000 ----

Created attachment 3937 [details] [review]
ics exported by evo with uid



---- Additional Comments From karlrt@gmx.net 2010-12-15 06:16:00 +0000 ----

Created attachment 3938 [details] [review]
ics exported by t700 missing the uid



---- Additional Comments From karlrt@gmx.net 2010-12-22 02:30:39 +0000 ----

might not be important but not fixed in 1.1.0.99.1



---- Additional Comments From patrick.ohly@intel.com 2012-05-15 13:28:18 +0000 ----

All the requested information was provided - but I have no idea how to work around this problem.



--- Bug imported by patrick.ohly@gmx.de 2012-07-29 20:36 UTC  ---

This bug was previously known as _bug_ 10131 at https://bugs.meego.com/show_bug.cgi?id=10131
Imported an attachment (id=64863)
Imported an attachment (id=64864)
Comment 1 GitLab Migration User 2018-10-13 12:43:08 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/99.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.