Bug 52887 - CalDAV + Google: incorrect 404 for GET
Summary: CalDAV + Google: incorrect 404 for GET
Status: RESOLVED WORKSFORME
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-16 21:13 UTC by Patrick Ohly
Modified: 2013-11-28 16:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Patrick Ohly 2012-07-29 18:36:00 UTC


---- Reported by patrick.ohly@intel.com 2011-06-16 21:13:27 +0000 ----

From a testManyItems test:

[INFO @google 00:03:16] @google/calendar: adding "030-phone meeting, 030-my office"
[DEBUG @google 00:03:16] starting PUT
[DEBUG @google 00:03:17] update item status: <status 1.1, code 201, class 2, Created>
[DEBUG @google 00:03:17] starting PROPFIND
[DEBUG @google 00:03:17] item UNIQUE-UID-1308257075-030-UNIQUE-UID-1308257075-1234567890@dummy.ics = rev 63443940431
[DEBUG @google 00:03:17] starting GET
[DEBUG @google 00:03:18] resending VEVENT to get rid of VALARM
[DEBUG @google 00:03:18] starting PUT
[DEBUG @google 00:03:19] update item status: <status 1.1, code 204, class 2, No Content>
[DEBUG @google 00:03:19] starting PROPFIND
[DEBUG @google 00:03:19] PROPFIND: Neon error code 1: 404 Not Found, must not retry
[DEBUG @google 00:03:19] @google/calendar: exception thrown at /home/pohly/syncevolution/syncevolution/src/backends/webdav/NeonCXX.cpp:649
[ERROR @google 00:03:19] @google/calendar: error code from SyncEvolution object not found (remote, status 404): PROPFIND: Neon error code 1: 404 Not Found

This is a temporary error, trying again (as in a --print-items command line operation) shows the event:
UNIQUE-UID-1308257075-030-UNIQUE-UID-1308257075-1234567890%40dummy%2eics: 030-phone meeting, 030-my office

The retry mechanism should be triggered in those cases where we are pretty sure that 404 must be incorrect.



--- Bug imported by patrick.ohly@gmx.de 2012-07-29 20:36 UTC  ---

This bug was previously known as _bug_ 19433 at https://bugs.meego.com/show_bug.cgi?id=19433
Comment 1 Patrick Ohly 2013-11-28 16:17:08 UTC
Haven't seen this lately. Might be obsolete.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.