Bug 53286 - Compile fixes for Solaris
Summary: Compile fixes for Solaris
Status: RESOLVED FIXED
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: All Solaris
: medium blocker
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
: 54665 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-09 10:17 UTC by Jonathan Perkin
Modified: 2012-09-08 11:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Patches to fix Solaris compilation (792 bytes, application/octet-stream)
2012-08-09 10:17 UTC, Jonathan Perkin
Details

Description Jonathan Perkin 2012-08-09 10:17:13 UTC
Created attachment 65339 [details]
Patches to fix Solaris compilation

dbus 1.6.4 requires these two patches to build correctly on Solaris.

Firstly, __EXTENSIONS__ is required for sockaddr_in6 and sockaddr_storage.

Secondly, HAVE_DECL_LOG_PERROR is always defined, so use #if not #ifdef to
check whether it is 0 or 1.

Thanks.
Comment 1 Simon McVittie 2012-08-09 11:44:00 UTC
Thanks, I've applied a slightly modified version. Fixed in git for 1.6.6 and 1.7.0.

For future reference, we ideally prefer patches in "git am" format, one patch per change (or very closely related set of changes); and configure isn't really source code, configure.ac is the thing to patch. Your patch turned into these commits:

http://cgit.freedesktop.org/dbus/dbus/commit/?id=e98107548c5cd0a9da9d5a15e20177be0e479459

http://cgit.freedesktop.org/dbus/dbus/commit/?id=ed0e9e982e720d56274d5c0b2cf4fe2f983f9cc4
Comment 2 Igor Pashev 2012-09-08 11:23:06 UTC
*** Bug 54665 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.