Bug 53305 - [snb] vga-1 erroneously detected as connected
Summary: [snb] vga-1 erroneously detected as connected
Status: RESOLVED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Daniel Vetter
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-09 19:23 UTC by Maarten Lankhorst
Modified: 2012-09-03 09:01 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten Lankhorst 2012-08-09 19:23:12 UTC
The problem is that if the computer boots up and shows the login screen the login screen appears with 1024x768 resolution and not with the monitor's native 1920x1080. The driver is actually the intel driver (no fallback to VESA). After login I can correct thedisplay to 1920x1080 with the "Displays" section of the System Settings and this persists when I log out an log in again, only the login screen and the desktop of every new user stays 1024x768.

The problem seems that there are more than the two (HDMI and DisplayPort) displays reported by the driver, according to the xrandr output. Especially there is a "VGA1" display always considered as connected and with max resolution of 1024x768. This seems to somehow determine the default resolution, probably because the standard multi-monitor mode is mirroring and due to the VGA1 ghost display also a system with one monitor and one monitor cable is already in multi-monitor mode.

syslog with drm.debug=0xe: https://launchpadlibrarian.net/111274170/syslog
Comment 1 Chris Wilson 2012-08-10 07:10:51 UTC
The hw is convinced something is attached. Is the physical connector dirty? Does plugging in and removing a real monitor clear the erroneous state? Does Windows work?

About the only brute force you have available is to do a forced hw probe instead of checking the state changed, or to always use the EDID detection (which then breaks those monitors without EDID).
Comment 2 Daniel Vetter 2012-08-22 09:34:02 UTC
What does Windows do here (if you can test this ...)? Since the vga hotplug logic is all in hw in snb, there's not much we can do to prevent this, I fear ...
Comment 3 Till Kamppeter 2012-09-02 20:45:51 UTC
I do not have Windows here. So I cannot do Windows tests.
Comment 4 Daniel Vetter 2012-09-03 09:01:53 UTC
Ok, till we have evidence to the contrary I'll shrug this off as a hw bogosity ... crt detection is a funky business and we get way too much hate-mail from people because every time we touch it we break something. So I prefer not to touch it. Since you can easily work around the issue with xrandr, shouldn't be to horrid.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.