Bug 53319 - [softpipe] sp_texture.c:322:softpipe_get_transfer: Assertion `level <= resource->last_level' failed.
[softpipe] sp_texture.c:322:softpipe_get_transfer: Assertion `level <= resour...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
git
x86-64 (AMD64) Linux (All)
: medium critical
Assigned To: mesa-dev
:
: 53321 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 05:46 UTC by Vinson Lee
Modified: 2012-08-10 15:47 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2012-08-10 05:46:17 UTC
mesa: 6cb9e99a757bd5a9d908ed6c5515a9ae5fb041ba (master)

Run WebGL Conformance Tests conformance/misc/type-conversion-test.html on softpipe.


(gdb) bt
#0  _debug_assert_fail (
    expr=expr@entry=0x7f31d67610d4 "level <= resource->last_level", 
    file=file@entry=0x7f31d6761094 "sp_texture.c", line=line@entry=322, 
    function=function@entry=0x7f31d67613a0 "softpipe_get_transfer")
    at util/u_debug.c:281
#1  0x00007f31d64c2ddf in softpipe_get_transfer (pipe=0x7f31db542000, 
    resource=0x7f31e3e80590, level=2, usage=2, box=0x7fffbb87bfa0)
    at sp_texture.c:322
#2  0x00007f31d66f326e in pipe_get_transfer (h=1, w=1, y=0, x=0, 
    usage=PIPE_TRANSFER_WRITE, layer=<optimized out>, level=2, 
    resource=0x7f31e3e80590, context=0x7f31db542000) at ./util/u_inlines.h:417
#3  util_resource_copy_region (pipe=0x7f31db542000, dst=0x7f31e3e80590, 
    dst_level=2, dst_x=0, dst_y=0, dst_z=<optimized out>, src=0x7f31e3f0fbd0, 
    src_level=0, src_box=0x7fffbb87c0c0) at util/u_surface.c:179
#4  0x00007f31d6582ab2 in st_CopyTexSubImage (ctx=0x7f31de894000, 
    dims=<optimized out>, texImage=0x7f31dbd88140, destX=0, destY=0, destZ=0, 
    rb=0x7f31dbee59d0, srcX=0, srcY=0, width=1, height=1)
    at ../../src/mesa/state_tracker/st_cb_texture.c:1011
#5  0x00007f31d65623e1 in copyteximage (ctx=0x7f31de894000, dims=dims@entry=2, 
    target=target@entry=3553, level=2, internalFormat=6408, x=0, y=0, width=1, 
    height=height@entry=1, border=border@entry=0)
    at ../../src/mesa/main/teximage.c:2957
#6  0x00007f31d6563b33 in _mesa_CopyTexImage2D (target=3553, 
    level=<optimized out>, internalFormat=<optimized out>, x=<optimized out>, 
    y=<optimized out>, width=<optimized out>, height=1, border=0)
    at ../../src/mesa/main/teximage.c:2996
#7  0x00007f31f86b1ee4 in ?? () from /usr/lib/firefox/libxul.so
#8  0x00007f31f86b7ed3 in ?? () from /usr/lib/firefox/libxul.so
#9  0x00007f31f8d3bfdb in ?? () from /usr/lib/firefox/libxul.so
#10 0x00007f31f905e68a in ?? () from /usr/lib/firefox/libxul.so
#11 0x00007f31f904fe02 in ?? () from /usr/lib/firefox/libxul.so
#12 0x00007f31f905db9d in ?? () from /usr/lib/firefox/libxul.so
#13 0x00007f31f905dd4b in ?? () from /usr/lib/firefox/libxul.so
#14 0x00007f31f906ee09 in ?? () from /usr/lib/firefox/libxul.so
#15 0x00007f31f906f601 in ?? () from /usr/lib/firefox/libxul.so
#16 0x00007f31f923c988 in ?? () from /usr/lib/firefox/libxul.so
#17 0x00007f31efcca527 in ?? ()
#18 0x00007f31efcca328 in ?? ()
#19 0x000000000000010b in ?? ()
#20 0x0000000000000000 in ?? ()
(gdb) frame 1
#1  0x00007f31d64c2ddf in softpipe_get_transfer (pipe=0x7f31db542000, 
    resource=0x7f31e3e80590, level=2, usage=2, box=0x7fffbb87bfa0)
    at sp_texture.c:322
322	   assert(level <= resource->last_level);
(gdb) print resource->last_level
$1 = 0
Comment 1 Vinson Lee 2012-08-10 06:53:10 UTC
*** Bug 53321 has been marked as a duplicate of this bug. ***
Comment 2 Brian Paul 2012-08-10 15:47:07 UTC
Fixed with 9b04abe36812a34ba447e5b1f8d8e44a10510820.