Bug 53730 - Sync app UI needs to be updated to fit all languages
Summary: Sync app UI needs to be updated to fit all languages
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: GTK UI (show other bugs)
Version: unspecified
Hardware:
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-04 10:57 UTC by SyncEvolution Community
Modified: 2018-10-13 12:43 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Sync window (deleted)
2010-05-04 10:57 UTC, SyncEvolution Community
Details

Description Patrick Ohly 2012-08-19 18:56:45 UTC


---- Reported by tomas.galicia@intel.com 2010-05-04 10:57:12 +0000 ----

Created attachment 624 [details] [review]
Sync window

Build Image(2010-4-30):
Hardware Model (on what HW this bug is uncovered): n/a

Bug detailed descriptions(behavior, impact, etc)
===========================================================
The dialog needs 2 things:

Left pane: Since this button can be long, it's better to redesign the box altogether, making the yellow text go all the way to the right and positioning the button below the text.

Right pane: Many languages need bigger buttons - please make the right pane wider to avoid truncations

Reproduce Steps(steps,current result, reproduce possibility)
===========================================================
1. Run MeeGo
2. go to Application tab
3. select Internet
4. select Sync
5. see issue

Expected result:
===========================================================
see above


Possible root cause:
===========================================================



---- Additional Comments From jku@linux.intel.com 2010-05-04 12:28:23 +0000 ----

> Left pane: Since this button can be long, it's better to redesign the box
> altogether, making the yellow text go all the way to the right and positioning
> the button below the text.

GtkInfoBar is a standard component: We really don't want to change that. I think a better option is to make the button label multiline when needed, like this: "Seleziona servizio/ndi sincronizzazione".

A translator comment about the maximum line length would be good though. 

There is a _really good_ solution to this problem as well: height-for-width layout in GTK+: http://blogs.gnome.org/tvb/2010/04/22/gtk-learns-height-for-width-geometry/ . Then I wouldn't have to hard code the text width as I have to now... but even in that case I think multiline buttons make sense for 'long winded' languages like Italian.

> Right pane: Many languages need bigger buttons - please make the right pane
> wider to avoid truncations

The pane probably is too tight. I can't change that before release because thoroughly testing the effects of that on the main pane is not easy (as an example of possible problems: this would affect the spacing in the GtkInfoBar we discussed above).

I hope using multiline text will work here as well for the time being.



---- Additional Comments From patrick.ohly@gmx.de 2010-08-24 04:56:53 +0000 ----

Jussi, do you intend to work on this for 1.1?



---- Additional Comments From tomas.galicia@intel.com 2010-09-17 14:05:03 +0000 ----

still an issue in 1.1



---- Additional Comments From tomas.galicia@intel.com 2010-09-21 17:04:42 +0000 ----

(In reply to comment #3)
> still an issue in 1.1  

Created a separate bug for 1.1



--- Bug imported by patrick.ohly@gmx.de 2012-08-19 20:56 UTC  ---

This bug was previously known as _bug_ 1699 at https://bugs.meego.com/show_bug.cgi?id=1699
Imported an attachment (id=65793)

Unknown platform unknown. Setting to default platform "".
Unknown operating system unknown. Setting to default OS "".

Comment 1 GitLab Migration User 2018-10-13 12:43:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/116.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.