Bug 53746 - Configuration of a service can not be stored (Done button has no respnse)
Summary: Configuration of a service can not be stored (Done button has no respnse)
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: Maemo (show other bugs)
Version: unspecified
Hardware:
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-14 15:03 UTC by SyncEvolution Community
Modified: 2018-10-13 12:45 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
synfe.py with workaround (deleted)
2011-04-14 15:04 UTC, SyncEvolution Community
Details
config.ini in folder "calendar+todo" (deleted)
2011-04-15 00:05 UTC, SyncEvolution Community
Details

Description Patrick Ohly 2012-08-19 18:56:45 UTC


---- Reported by caco3@ruinelli.ch 2011-04-14 15:03:28 +0000 ----

When selecting a service and open it for editing, the done button has no action.
The terminal shows that there is an error:
--------------------
Traceback (most recent call last):
  File "/opt/syncevolution/syncfe.py", line 565, in edit_server
    self.init_server_edit()
  File "/opt/syncevolution/syncfe.py", line 806, in init_server_edit
    source_config["evolutionsource"] = base_list[idx][1]
IndexError: list index out of range
---------------------
Interestingly, if run as root, it works fine.
Looking for differences, I see that (if run as root), the following entry in the config window is missing:
calendar+todo database

As a quick workaround, replace line 806-807 in syncfe.py with (see attachment):
---------------------
        if(idx<0): #Workaround by George Ruinelli
	  print "index out of range"
	else:
	  source_config["evolutionsource"] = base_list[idx][1]
	  self.sync.set_source_config(config, name, source_config)
---------------------

OS: Maemo 1.3
SyncEvolution: 0.9
syncevolution: 1.1.1-1



---- Additional Comments From caco3@ruinelli.ch 2011-04-14 15:04:07 +0000 ----

Created attachment 5625 [details]
synfe.py with workaround



---- Additional Comments From patrick.ohly@gmx.de 2011-04-14 17:59:03 +0000 ----

Ove, does this patch look reasonable?

Note that caco3 has also expressed some interest with helping SyncEvolution on N900, see https://bugs.meego.com/show_bug.cgi?id=15992 comment #2. I asked because I didn't know how active you still were. In the meantime you clarified on the mailing list that you are only waiting for a stable release, so there might not be much to do. Anyway, I'll leave to you two to figure out the next steps.



---- Additional Comments From ovek@debian.org 2011-04-14 20:58:13 +0000 ----

Not really. I think I'd like to know more about the configuration in use here (what's in the config file, what sources are listed if you type "syncevolution", do you have a source without a local DB, etc). If possible, find out which source is the problem.



---- Additional Comments From caco3@ruinelli.ch 2011-04-14 22:35:15 +0000 ----

It is definitely not a bug fix! See it more as a dirty workaround so it works again for me!
I thought I post it so others with the same issue have a quick solution until it is fixed.

I now removed the whole folder syncevolution in /home/user/.config to give it a clear start. To my surprise it now worked fine.
After comparing the old and new files, I figured out that the old (broken) config had a folder "calendar+todo" in /home/user/.config/syncevolution/default/sources/ . 
After removing the folder and its containing config.ini it now works correctly.
I don’t know why this folder was there, maybe from an old version?
In any case, my dirty bug fix did exactly what was needed, ignoring the "calendar+todo" config.


BTW: There is another issue with the GUI:
In the wizard, when you create a new service and enter the username and password, the fist letter is a capital letter! This "autocorrelation" should somehow be disabled, especially for the password.

And I also would have a wish:
After a successful sync a notification message gets shown. How every it disappears again after a few seconds. This is ok for an auto sync, but for the manual sync we should use the other type of notifications (see http://wiki.maemo.org/Phone_control#Send_dialog_notification_.28orange_multi_line_popup_requiring_user_interaction.29_2), the one which has to be acknowledged by the user. This way he sees on a manual sync if it was successful.
Also, if an auto sync fails, I would suggest to use the second type of notifications.

I used both in my Python application SleepAnalyser, so if you want I could try to write a patch for this.



---- Additional Comments From ovek@debian.org 2011-04-14 23:18:17 +0000 ----

> After comparing the old and new files, I figured out that the old (broken)
> config had a folder "calendar+todo" in
> /home/user/.config/syncevolution/default/sources/ . 
> After removing the folder and its containing config.ini it now works correctly.

Well, regardless, it's probably a good idea to try to fix the crash. What was in that config.ini?

> the one which has to be acknowledged by the user. This way he sees on a manual
> sync if it was successful.

Why, on manual sync he'll know it was successful because the progress dialog will go away without showing an error...

> Also, if an auto sync fails, I would suggest to use the second type of
> notifications.

That already happens.



---- Additional Comments From caco3@ruinelli.ch 2011-04-15 00:05:22 +0000 ----

Created attachment 5660 [details] [review]
config.ini in folder "calendar+todo"



---- Additional Comments From caco3@ruinelli.ch 2011-04-15 00:07:36 +0000 ----

(In reply to comment #5)
> > After comparing the old and new files, I figured out that the old (broken)
> > config had a folder "calendar+todo" in
> > /home/user/.config/syncevolution/default/sources/ . 
> > After removing the folder and its containing config.ini it now works correctly.
> 
> Well, regardless, it's probably a good idea to try to fix the crash. What was
> in that config.ini?
See attachment

> > the one which has to be acknowledged by the user. This way he sees on a manual
> > sync if it was successful.
OK, I didnât know that
> 
> Why, on manual sync he'll know it was successful because the progress dialog
> will go away without showing an error...
> 
> > Also, if an auto sync fails, I would suggest to use the second type of
> > notifications.
> 
> That already happens.    
Cool.
Where can I get the sources from?
Are they also on a place like https://garage.maemo.org/ ?



---- Additional Comments From ovek@debian.org 2011-04-15 10:39:50 +0000 ----

Hm, yes, this is probably what a standard calendar+todo configuration would look like, but it's a configuration the frontend don't currently handle. Since some of the templates would probably create such a configuration, I guess I should find a reasonable way to handle it... or at least make it fail gracefully.



--- Bug imported by patrick.ohly@gmx.de 2012-08-19 20:56 UTC  ---

This bug was previously known as _bug_ 16074 at https://bugs.meego.com/show_bug.cgi?id=16074
Imported an attachment (id=65797)
Imported an attachment (id=65798)

Unknown platform unknown. Setting to default platform "".
Unknown operating system unknown. Setting to default OS "".

Comment 1 GitLab Migration User 2018-10-13 12:45:00 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/141.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.