Bug 53771 - Seems like Sync UI should allow multiple accounts to show at same time
Summary: Seems like Sync UI should allow multiple accounts to show at same time
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: GTK UI (show other bugs)
Version: unspecified
Hardware:
: low enhancement
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-29 22:00 UTC by SyncEvolution Community
Modified: 2018-10-13 12:44 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Patrick Ohly 2012-08-19 18:56:45 UTC


---- Reported by noel.c.arnold@intel.com 2010-04-29 22:00:18 +0000 ----

Build Image(2010-04-27):
Hardware Model (on what HW this bug is uncovered):NB305-N410BN

Bug detailed descriptions(behavior, impact, etc)
===========================================================
In the unnamed network sync page, I can only have one sync acct shown at a time. Seems like it would make sense to allow users to list more than one account....

Reproduce Steps(steps,current result, reproduce possibility)
===========================================================
(1) open the synd app
(2) set up an acct
(3) set up another acct
(4) note that you have to switch accts using change or edit sync service button, instead of seeing them all on the same page and just selecting the one you want.
(5)


Expected result:
===========================================================
seeing all sync accounts on the same page and just select the one you want.


Possible root cause:
===========================================================



---- Additional Comments From jku@linux.intel.com 2010-04-30 00:38:16 +0000 ----

Noel, you must understand this is a core design decision of the application and cannot be changed after the code freeze. This is not a release blocker by any stretch of imagination.


We do realise people may want to sync with several peers at the same time (say a phone and a web service), but designing and implementin the UI for that is not trivial. Assigning to Nick as enhancement.



---- Additional Comments From nicholas.e.richards@intel.com 2010-04-30 05:14:59 +0000 ----

Also, until very, very recently it was a core constraint of the library that we just couldn't do it. As jussi says - if this is a blocker it will require a total redesign and reimplementation of the sync infrastructure and UI.



---- Additional Comments From noel.c.arnold@intel.com 2010-04-30 09:11:57 +0000 ----

Right, Jing (my apologies if I'm getting your name wrong - hard to tell from the abbreviations used in the bug reporting software), and you'll also note that I listed the target milestone as 1.1.... I am aware, I just wanted to note it while I was in the window so I didn't forget.



---- Additional Comments From kaitlin.rupert@linux.intel.com 2010-05-03 10:27:58 +0000 ----

Rejecting this issue for 1.0 as it's not a showstopper.  This issue shouldn't block the 1.0 release.



---- Additional Comments From jingke.zhang@intel.com 2010-05-05 19:04:45 +0000 ----

This is an enhancement issue. Move it to upstream to check. Thanks!



--- Bug imported by patrick.ohly@gmx.de 2012-08-19 20:56 UTC  ---

This bug was previously known as _bug_ 1535 at https://bugs.meego.com/show_bug.cgi?id=1535

Unknown platform unknown. Setting to default platform "".
Unknown operating system unknown. Setting to default OS "".

Comment 1 GitLab Migration User 2018-10-13 12:44:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/130.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.