Bug 53776 - support suspend/abort
Summary: support suspend/abort
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: GTK UI (show other bugs)
Version: unspecified
Hardware:
: medium enhancement
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-19 19:22 UTC by SyncEvolution Community
Modified: 2018-10-13 12:44 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Patrick Ohly 2012-08-19 18:56:45 UTC


---- Reported by jingke.zhang@intel.com 2010-04-19 19:22:02 +0000 ----

This is from http://bugzilla.moblin.org/show_bug.cgi?id=2309

   Description  From  jku   2009-05-13 11:52:48 PST   (-) [reply]

Any sort of canceling of sync is currently disabled. 

We should support suspend and/or resume. For reference this is roughly what
they mean:

abort: tell server communication ends now. This will probably lead to a slow
sync next time.
suspend: ask server to suspend the sync session. Server may or may not do that.

Patricks idea about the UI: when sync starts the Sync-button turns into
"suspend"-button. If user clicks suspend it turns into "abort"-button.
Alternatively the "Cancel" button could open a dialog with those two choices
and an explanation text.

------- Comment #1 From ZhangJingke 2009-06-14 20:19:04 PST (-) [reply] -------

*** https://bugs.meego.com/show_bug.cgi?id=3097 has been marked as a duplicate of this bug. ***

------- Comment #2 From pohly 2009-07-03 01:23:38 PST (-) [reply] -------

We have the infrastructure now, but it is uncertain how well servers support
it. Let's postpone till after 0.9.

------- Comment #3 From ZhangJingke 2009-08-11 19:21:18 PST (-) [reply] -------

It is good idea to support "suspend" and "abort" buttons, but we may be careful
for it (especially on Server side). 

CC to Nick and hope to discuss it in near future. :)



--- Bug imported by patrick.ohly@gmx.de 2012-08-19 20:56 UTC  ---

This bug was previously known as _bug_ 994 at https://bugs.meego.com/show_bug.cgi?id=994

Unknown platform unknown. Setting to default platform "".
Unknown operating system unknown. Setting to default OS "".

Comment 1 GitLab Migration User 2018-10-13 12:44:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/128.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.