Bug 5450 - radeon drm v1.21.0 freezes X.Org 6.9.0 with ATI FireGL Mobility T2
radeon drm v1.21.0 freezes X.Org 6.9.0 with ATI FireGL Mobility T2
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/other
DRI git
x86 (IA32) Linux (All)
: high critical
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-29 23:40 UTC by Pekka Panula
Modified: 2006-07-29 03:08 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pekka Panula 2005-12-29 23:40:06 UTC
New Radeon driver 1.21.0 from dri cvs freezes my X.Org R6.9.0. 
Radeon 1.20.0 works with my IBM Laptop T42p fine, no lockups.
Adapter is M10 NT, ATI FireGL Mobility T2.
Machine is IBM Laptop, 2373-F4G
Linux Kernel 2.6.14.5.
Comment 1 Dave Airlie 2005-12-30 13:12:43 UTC
I doubt the 1.21 changes should affect anything.. its more likely the
radeon_cp.c changes but I only added that for a few days and it broke more than
it fixed so I reverted it..

Comment 2 Pekka Panula 2005-12-30 17:57:36 UTC
I fetched drm from cvs just now and nope, still freezes.
Some modification made 29.12.2005 did broke it, because i fetched 28.12.2005
version from cvs and it works ok. 
Comment 3 Tilman Sauerbeck 2006-01-02 05:56:50 UTC
Reverting the patch from radeon_cp.c rev. 1.71 fixes this bug for me.
Comment 4 Dave Airlie 2006-01-02 12:53:10 UTC
(In reply to comment #3)
> Reverting the patch from radeon_cp.c rev. 1.71 fixes this bug for me.

Ouch, this is messy to fixup, as the fix that went in on Dec 16th wasn't correct
(i.e. lots of other systems broke with it).. so I assume your system never
worked before then?

Ben was working on patch but it'll take a while, there are a few areas to change...
Comment 5 Tilman Sauerbeck 2006-01-02 18:32:46 UTC
Never worked before what date? I didn't use the Radeon DRI before 2005-12-23. Do
you want me to try the code from before 2005-12-16?
Comment 6 Steve Pomeroy 2006-02-15 08:41:26 UTC
X.Org 6.9.0 just made its way into Debian/testing and I just got hit with this
bug (or what may be this bug). It seems to freeze the entire system (but no
kernel panic blinking lights) after about 3-10 minutes of running Xorg, even
from gdm. It seem particularly fond of freezing while drawing to the screen.

This is on a Thinkpad T42p, M10 NT FireGL Mobility T2.
Reproduced in both stock Debian kernels: 2.6.15, 2.6.12

Perhaps #4847 is related?
Comment 7 Michel Dänzer 2006-02-16 02:30:22 UTC
Please test Benjamin Herrenschmidt's memmap patches, current versions:

http://gate.crashing.org/~benh/radeon-memmap-drm-4.diff
http://gate.crashing.org/~benh/radeon-memmap-7.0-3.diff

He posts updates to the xorg mailing list.
Comment 8 bd 2006-03-13 01:04:33 UTC
Not sure if this is related to #4324 but modular CVS HEAD stopped my X from
crashing.
Comment 9 mathew 2006-03-21 02:49:02 UTC
Just posting a "me too".

Radeon FireGL T2, ThinkPad T41p, Debian Testing, kernel 2.6.8 (Debian).

Upgrade to X.org 6.9 caused random freezes after a few minutes, or immediately 
if I tried to run anything involving OpenGL. I've reverted to 6.8. (Same config 
with both.)

On the plus side, it was definitely much faster until it froze :-)
Comment 10 Erik Andren 2006-07-28 10:06:24 UTC
Any improvement using current xorg/dri?
Comment 11 Jerome Glisse 2006-07-29 03:08:04 UTC
This should been fix with current ati driver (r300 initializatio
fix) thus i am closing the bug. Reopen it if you still have this
issue with newest ati driver.