Bug 550 - xauth doesn't unlock .Xauthority on SIGPIPE
Summary: xauth doesn't unlock .Xauthority on SIGPIPE
Status: CLOSED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xauth (show other bugs)
Version: 6.7.0
Hardware: SPARC Solaris
: low minor
Assignee: Alan Coopersmith
QA Contact:
URL: http://bugs.opensolaris.org/bugdataba...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-25 08:21 UTC by Alan Coopersmith
Modified: 2011-10-15 16:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Patch to xc/programs/xauth/process.c (286 bytes, patch)
2004-04-25 08:23 UTC, Alan Coopersmith
no flags Details | Splinter Review

Description Alan Coopersmith 2004-04-25 08:21:53 UTC
[Originally reported to Sun as Sun bug id #5025208, which is fixed in Solaris 10.]

A user writes:

I have a large number of entries in the .Xauthority file ...

xauth list | wc -l
     158

If I execute:

    xauth list | head

I get, as expected, the first 10. If I repeat the command I get ...

xauth list | head
xauth:  error in locking authority file .Xauthority

Sometime the failure doesn't happen (presumably because Xauth has removed the lock
before the SIGPIPE is delivered).

I confirmed this with my large .Xauthority and found the fix was simple - add
SIGPIPE to the list of signals that xauth catches with a routine to unlock the
.Xauthority file.
Comment 1 Alan Coopersmith 2004-04-25 08:23:24 UTC
Created attachment 235 [details] [review]
Patch to xc/programs/xauth/process.c
Comment 2 Alan Coopersmith 2004-04-25 09:31:05 UTC
Fix committed to HEAD:

Module name:	xc
Changes by:	alanc at pdx.	04/04/24 16:26:56

Log message:
  Bugzilla #550: xauth doesn't unlock .Xauthority on SIGPIPE

Modified files:
      xc/programs/xauth/:
        process.c 
  
  Revision      Changes    Path
  1.3           +4 -0      xc/programs/xauth/process.c





Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.