Bug 55061 - [SNB] Rendering artifacts in King's Bounty: The Legend
Summary: [SNB] Rendering artifacts in King's Bounty: The Legend
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-18 17:56 UTC by Nikita Tsukanov
Modified: 2014-09-21 18:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Tsukanov 2012-09-18 17:56:52 UTC
It's hard for me to describe, see the attached video.

The bug is definetely somewhere in MESA, since the game runs fine with the same Wine's version with nVidia card and when I've tried to run it in VMWare (3D support via WDDM driver) I've got the same result.

http://www.gamefront.com/files/11799044/Kings-Bounty-The-Legend-Demo/ - game demo.
Comment 1 Nikita Tsukanov 2012-09-18 18:08:42 UTC
Oops. Attachment is too large. Video is here: http://videobin.org/+611/6o0.html
Comment 2 Eric Anholt 2012-10-31 18:11:12 UTC
Ouch, that's bad.  We don't tend to work on issues with wine apps much, since it's a really painful environment to work in.  An apitrace (minimal as possible) of the app failing might be a way to bump the priority for us :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.