Bug 564 - uim-qt: cannnot enable IM when launching app on kicker
Summary: uim-qt: cannnot enable IM when launching app on kicker
Status: RESOLVED FIXED
Alias: None
Product: UIM
Classification: Unclassified
Component: bridge: Qt (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: high normal
Assignee: Kazuki Ohta
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-28 01:34 UTC by Kazuki Ohta
Modified: 2004-05-04 14:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Kazuki Ohta 2004-04-28 01:34:11 UTC
The application which is launched by clicking the button on kicker cannot 
enable qt-uim. 
But, the app launched by executing commands on the terminal can activete 
qt-uim. 
 
So, kdeinit may cause this problem?
Comment 1 Kazuki Ohta 2004-05-06 00:07:37 UTC
The bug is caused by the linking error.

This bug is fixed through this patch.
thx! Daisuke.

--- qt/quiminputcontextplugin/candidatewindow.cpp       2004-05-04
16:36:37.000000000 +0900
+++ kde-cvs/quiminputcontextplugin/candidatewindow.cpp  2004-05-05
11:11:40.000000000 +0900
@@ -34,6 +34,8 @@
     cList->setHScrollBarMode( QScrollView::AlwaysOff );
     QObject::connect( cList, SIGNAL(selectionChanged(QListViewItem *)),
                       this , SLOT(slotCandidateSelected(QListViewItem *)) );
+    QObject::connect( cList, SIGNAL(clicked(QListViewItem *)),
+                      this , SLOT(slotCandidateClicked(QListViewItem *)) );

     //setup NumberLabel
     numLabel = new QLabel(this, "candidateLabel");
@@ -177,6 +179,10 @@
     ic->lastKeyWidget()->setFocus();
}

+void CandidateWindow::slotCandidateClicked( QListViewItem * item )
+{
+}
+
void CandidateWindow::adjustCandidateWindowSize()
{
     int height = 0; 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.