Bug 56550 - [Regression] Artifacts, Windows re-drawing and slow movement since savage 2.3.6.1
Summary: [Regression] Artifacts, Windows re-drawing and slow movement since savage 2.3...
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/savage (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-29 22:52 UTC by Matias de la Cruz
Modified: 2018-08-10 20:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matias de la Cruz 2012-10-29 22:52:17 UTC
Since the latest savage drivers, starting with 2.3.6.1, the performance of the hardware (S3 SuperSavage IX/C) offers the following scenarios:

1) In autodetection mode, and the hardware reverting to ShadowFB, the screen is filled with artifacts once X is started (both in the login manager screen and, ultimately, once the desktop shows up). Windows movement speed and drawing apparently are not affected (as far as the screen full of artifacts allows to see which, unfortunately, isn't much).

2) Enabling the NoAccel option in the created xorg.conf file removes the artifacts. At the same time window re-draw is visible and its movement is slow. Also X easily tops the CPU use during the moving.

3) Enabling/Changing the AccelMethod to 'exa' (due to xorg-server 1.13 dropping xaa) in the created xorg.conf file leads to artifacts:

a) In some browser buttons/features

- Firefox's 'refresh' menu button or the internet traffic status bar surrounded by an artifact shadow) and slow page scrolling. 

b) In windows content 

- Thunar folder content being covered by an artifact curtain rendering it unreadable

- some web browser content (text mainly) that is displayed in a pop up window shows the same curtain and rendered unreadable

- random site options/buttons display the same pattern 

As in 2) the same window re-draw is visible and its movement is slow showing the same high CPU use behaviour.
Comment 1 GitLab Migration User 2018-08-10 20:46:14 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-savage/issues/3.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.