Bug 56668 - Memos from Memotoo have the wrong title
Summary: Memos from Memotoo have the wrong title
Status: RESOLVED NOTOURBUG
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: 1.3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-02 09:53 UTC by Daniel
Modified: 2012-11-05 14:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Daniel 2012-11-02 09:53:37 UTC
A memo in the web app of Memotoo has:
title: test
text: this is a test

After syncing in Evolution the memo is as follows:
title: this is a test
text: this is a test

The other way creating a memo in Evolution:
title: title
text: this is a test

After syncing and opening in the web browser from Memotoo:
title: (empty)
text: test
      this is a test

In Evolution it is
title: test
text: test
      this is a test

The title is not correctly handled. Syncing an new memo from Evolution to Memotoo the title is set automatically to the first line of the text field, which is OK. Normally I do that manually, because other devices and Outlook does not have a title field. But I would be nice if you fill the title field correctly, as Evolution has one. And when I sync a new memo from Memotoo the title is lost as you can see in my examples.

Ubuntu 10.04 32-Bit.
Comment 1 Patrick Ohly 2012-11-04 11:36:57 UTC
(In reply to comment #0)
> A memo in the web app of Memotoo has:
> title: test
> text: this is a test
> 
> After syncing in Evolution the memo is as follows:
> title: this is a test
> text: this is a test
> 
> The other way creating a memo in Evolution:
> title: title
> text: this is a test
> 
> After syncing and opening in the web browser from Memotoo:
> title: (empty)
> text: test
>       this is a test
> 
> In Evolution it is
> title: test
> text: test
>       this is a test
> 
> The title is not correctly handled.

The root cause is that memos have to be exchanged as plain text, because Memotoo doesn't support anything else - see also bug #56674.

> Syncing an new memo from Evolution to
> Memotoo the title is set automatically to the first line of the text field,
> which is OK. Normally I do that manually, because other devices and Outlook
> does not have a title field. But I would be nice if you fill the title field
> correctly, as Evolution has one.

What SyncEvolution can do and does is that it includes a title in the text that it sends, if the first line of the text is not already the same as that title.

What Memotoo should do is to take that first line as title when creating a memo from plain text. This cannot be enforced by SyncEvolution and needs to be changed on the Memotoo side.

That, or support vCalendar/iCalendar as format.

> And when I sync a new memo from Memotoo the
> title is lost as you can see in my examples.

That's because Memotoo only sends plain text and probably doesn't include the title in the data that it sends. Needs to be fixed on the Memotoo side, by adding support for vCalendar 1.0 or iCalendar 2.0 (better) - see also bug #56674.
Comment 2 Daniel 2012-11-05 14:49:57 UTC
Thank you, I will check with Memotoo.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.