Bug 5679 - Vertical line ghosting with X700 on 1680x1050@60 LCD
Summary: Vertical line ghosting with X700 on 1680x1050@60 LCD
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.0.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-22 02:11 UTC by Nicolas Mailhot
Modified: 2009-04-03 01:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (4.22 KB, text/plain)
2006-01-22 02:14 UTC, Nicolas Mailhot
no flags Details
Xorg.0.log (148.59 KB, text/plain)
2006-01-22 02:15 UTC, Nicolas Mailhot
no flags Details
lspci (22.05 KB, text/plain)
2006-01-22 02:15 UTC, Nicolas Mailhot
no flags Details
Effect on a complex moving picture (mpeg2 stream) (123.66 KB, image/jpeg)
2006-01-22 03:01 UTC, Nicolas Mailhot
no flags Details

Description Nicolas Mailhot 2006-01-22 02:11:59 UTC
I've just replaced my old trusty crt with a new LCD intending to get as long us
of the new sceen as I had of the old one. Unfortunately the image of the new LCD
under Linux is very bad (it's perfect under that other OS, using what the screen
says is the same resolution - the one recommended by the manufacturer).

A uniform single-color surface is replaced by one with light gray vertical
stripes (depending of the color, the effect is more or less pronouced)

Moving an object over it (mouse, window) distorts the stripes following the
object shape (only to the right of the shape)

Hardware is a PCIE X700 + a Belinea 10 20 35W screen
Software is current Fedora Core Devel

The same effect happens both under EXA and XAA
Comment 1 Nicolas Mailhot 2006-01-22 02:14:41 UTC
Created attachment 4415 [details]
xorg.conf
Comment 2 Nicolas Mailhot 2006-01-22 02:15:19 UTC
Created attachment 4416 [details]
Xorg.0.log
Comment 3 Nicolas Mailhot 2006-01-22 02:15:53 UTC
Created attachment 4417 [details]
lspci
Comment 4 Nicolas Mailhot 2006-01-22 02:16:44 UTC
xorg packages on system :

xorg-x11-apps-1.0.0-1
xorg-x11-drivers-0.99.2-4
xorg-x11-drv-acecad-1.0.0.4-1
xorg-x11-drv-aiptek-1.0.0.4-1
xorg-x11-drv-ati-6.5.7.2-1
xorg-x11-drv-ati-debuginfo-6.5.7.2-1
xorg-x11-drv-calcomp-1.0.0.4-1
xorg-x11-drv-citron-2.1.1.4-1
xorg-x11-drv-digitaledge-1.0.1.2-1
xorg-x11-drv-dmc-1.0.0.4-1
xorg-x11-drv-dummy-0.1.0.4-1
xorg-x11-drv-dynapro-1.0.0.4-1
xorg-x11-drv-elo2300-1.0.0.4-1
xorg-x11-drv-elographics-1.0.0.4-1
xorg-x11-drv-evdev-1.0.0.4-1
xorg-x11-drv-fbdev-0.1.0.4-1
xorg-x11-drv-fpit-1.0.0.4-1
xorg-x11-drv-hyperpen-1.0.0.4-1
xorg-x11-drv-i810-1.4.1.2-1
xorg-x11-drv-jamstudio-1.0.0.4-1
xorg-x11-drv-joystick-1.0.0.4-1
xorg-x11-drv-keyboard-1.0.1.2-1
xorg-x11-drv-keyboard-debuginfo-1.0.1.2-1
xorg-x11-drv-magellan-1.0.0.4-1
xorg-x11-drv-magictouch-1.0.0.4-1
xorg-x11-drv-mga-1.2.1.2-1
xorg-x11-drv-microtouch-1.0.0.4-1
xorg-x11-drv-mouse-1.0.3-1
xorg-x11-drv-mouse-debuginfo-1.0.3-1
xorg-x11-drv-mutouch-1.0.0.4-1
xorg-x11-drv-nv-1.0.1.4-1
xorg-x11-drv-palmax-1.0.0.4-1
xorg-x11-drv-penmount-1.0.0.4-1
xorg-x11-drv-s3-0.3.5.4-1
xorg-x11-drv-s3virge-1.8.6.4-1
xorg-x11-drv-savage-2.0.2.2-1
xorg-x11-drv-siliconmotion-1.3.1.4-1
xorg-x11-drv-sis-0.8.1.2-1
xorg-x11-drv-sisusb-0.7.1.2-1
xorg-x11-drv-spaceorb-1.0.0.4-1
xorg-x11-drv-summa-1.0.0.4-1
xorg-x11-drv-tdfx-1.1.1.2-1
xorg-x11-drv-trident-1.0.1.1-1
xorg-x11-drv-ur98-1.0.0.4-1
xorg-x11-drv-vesa-1.0.1.2-1
xorg-x11-drv-vesa-debuginfo-1.0.1.2-1
xorg-x11-drv-vga-4.0.0.4-1
xorg-x11-drv-via-0.1.33.1-1
xorg-x11-drv-vmware-10.11.1.2-1
xorg-x11-drv-void-1.0.0.4-1
xorg-x11-drv-voodoo-1.0.0.4-1
xorg-x11-filesystem-0.99.2-3
xorg-x11-fonts-base-1.0.0-3
xorg-x11-fonts-truetype-1.0.0-3
xorg-x11-fonts-Type1-1.0.0-3
xorg-x11-font-utils-1.0.0-1
xorg-x11-font-utils-1.0.0-1
xorg-x11-font-utils-debuginfo-1.0.0-1
xorg-x11-proto-devel-7.0-1
xorg-x11-resutils-1.0.0-1
xorg-x11-server-utils-1.0.0-1
xorg-x11-server-Xorg-1.0.0-3
xorg-x11-utils-1.0.0-1
xorg-x11-xauth-1.0.0-1
xorg-x11-xdm-1.0.1-1
xorg-x11-xfs-1.0.0-2
xorg-x11-xfs-debuginfo-1.0.0-2
xorg-x11-xfs-utils-1.0.0-2
xorg-x11-xinit-1.0.0-1
xorg-x11-xinit-debuginfo-1.0.0-1
xorg-x11-xkbdata-1.0.0-1
xorg-x11-xkb-utils-1.0.0-1
xorg-x11-xkb-utils-debuginfo-1.0.0-1
xorg-x11-xsm-1.0.0-1
Comment 5 Nicolas Mailhot 2006-01-22 03:01:39 UTC
Created attachment 4422 [details]
Effect on a complex moving picture (mpeg2 stream)

On a video the end result is so bad even an old digital camera is able to
capture it
Comment 6 Nicolas Mailhot 2006-02-03 10:25:14 UTC
I invested in a better cable and the problem is gone. So it seems the CRT cable
was not good enough for the xorg driver

(strangely the display worked fine under windows with the same cable, so Ati's
driver must have some magic missing from the xorg driver)
Comment 7 Adam Jackson 2008-02-24 18:22:20 UTC
Mass reopen.  The "LATER" resolution is lame, I'm deleting it.  Consider LATER to have arrived.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.