Bug 57919 - Visual glitches in unity with Radeon HD 7600M
Summary: Visual glitches in unity with Radeon HD 7600M
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2012-12-05 18:21 UTC by Thilo Cestonaro
Modified: 2016-02-26 03:19 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:

dmesg output (71.25 KB, text/plain)
2012-12-05 18:21 UTC, Thilo Cestonaro
LIBGL_DEBUG=verbose glxinfo >glxinfo_libgl_debug_verbose.txt 2>&1 (25.85 KB, text/plain)
2012-12-05 18:21 UTC, Thilo Cestonaro
Xorg log (39.15 KB, text/plain)
2012-12-05 18:22 UTC, Thilo Cestonaro
LiveCD GlxInfo 03/11/13 (25.92 KB, text/plain)
2013-03-11 19:49 UTC, Thilo Cestonaro
possible fix (1.73 KB, patch)
2013-03-11 23:41 UTC, Alex Deucher
Details | Splinter Review
possible fix (2.64 KB, patch)
2013-04-08 16:47 UTC, Alex Deucher
Details | Splinter Review
possible fix (1.91 KB, patch)
2013-10-01 23:26 UTC, Alex Deucher
Details | Splinter Review

Description Thilo Cestonaro 2012-12-05 18:21:03 UTC
Created attachment 71035 [details]
dmesg output


there are visual glichtes in unity and wine64 (executing WorldOfWarcraf-64.exe) using mesa lastest from git and xf86-video-ati from git, with kernel 3.7.0-4-generic (Ubuntu pre 13.04).

Unity Glitches: http://cestona.ro/~ephraim/public/unity.ogv
WoW Client: http://cestona.ro/~ephraim/public/Radeon_7600M.ogv
Comment 1 Thilo Cestonaro 2012-12-05 18:21:40 UTC
Created attachment 71036 [details]
LIBGL_DEBUG=verbose glxinfo >glxinfo_libgl_debug_verbose.txt 2>&1
Comment 2 Thilo Cestonaro 2012-12-05 18:22:05 UTC
Created attachment 71037 [details]
Xorg log
Comment 3 Thilo Cestonaro 2012-12-05 18:27:25 UTC
mesa git:
         automake/gallium: attempt to fix -lrt

xf86-video-ati git:
         radeon: avoid copying over itself ddx fb

uname -a
Linux errorl 3.7.0-4-generic #12-Ubuntu SMP Tue Nov 27 23:13:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

xorg 7.7+1ubuntu4

Anything else needed?

Comment 4 Thilo Cestonaro 2013-03-11 19:47:28 UTC
Tried with cdimage:

Still very ugly glitches!

Please, if I can provide any more details or something, tell me!

I added a glxinfo output again of the version of the used libgl stuff.
Anyway, as it was the livecd boot, I can reproduce it very easily.

Comment 5 Thilo Cestonaro 2013-03-11 19:49:31 UTC
Created attachment 76350 [details]
LiveCD GlxInfo 03/11/13

another LIBGL_DEBUG=verbose glxinfo output. This time generated by binaries from the livecd of 03/11/13 of ubuntu raring ringtail.
Comment 6 Alex Deucher 2013-03-11 23:41:52 UTC
Created attachment 76354 [details] [review]
possible fix

Does the attached kernel patch fix the issue?
Comment 7 Florian Mickler 2013-03-24 10:20:37 UTC
A patch referencing this bug report has been merged in Linux v3.9-rc4:

commit 8f612b23a17dce86fef75407e698de6243cc99a1
Author: Alex Deucher <alexander.deucher@amd.com>
Date:   Mon Mar 11 19:28:39 2013 -0400

    drm/radeon: fix backend map setup on 1 RB trinity boards
Comment 8 Thilo Cestonaro 2013-03-28 22:33:45 UTC
Finally I found some time do reinstall Ubuntu and compile the kernel with the patch. Sadly it doesn't fix the issue. :(

Comment 9 Thilo Cestonaro 2013-03-29 08:43:04 UTC
Forgot to mention, which versions I used. 
The Ubuntu I installed was raring latest with selfcompiled kernel 3.8.4 (from http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-raring.git).

Comment 10 Alex Deucher 2013-03-29 13:11:52 UTC
Does disabling tiling help?

Option "ColorTiling2D" "false"

in the device section of your xorg.conf?
Comment 11 Thilo Cestonaro 2013-03-29 14:23:07 UTC
Do you think, the Kernel patch fixed something which works together with the tiling option. If not, we tried this already last year (Nov.)


But I will give it a try.

Comment 12 Thilo Cestonaro 2013-03-29 14:35:22 UTC
I tried both with the patched kernel, only ColorTiling2D and ColorTiling plus ColorTiling2D.
The glitches still occur.

Any other ideas?

Greetings Thilo
Comment 13 Alex Deucher 2013-04-08 16:47:30 UTC
Created attachment 77616 [details] [review]
possible fix

Does this kernel patch fix the issue?
Comment 14 Thilo Cestonaro 2013-04-10 20:24:49 UTC
Sadly I must say, that this patch changes the behave in no way, too. :( ...

It's still flickering and showing theses glitches as in the video.

Could I add any debug output, any printks which would help to identify the problem? 
Anything else I should test? 
Currently I'm testing on raring latest with following kernel + the two patches mentioned in this thread.


Comment 15 Thilo Cestonaro 2013-04-10 20:28:28 UTC
The first is already part of the kernel, so it's the kernel + the second patch.

Comment 16 Thilo Cestonaro 2013-04-26 08:01:50 UTC
Any news about this prob? Any questions? Additional Info needed?

Comment 17 Thilo Cestonaro 2013-05-10 06:18:11 UTC
Hey ho,

I updated to ubuntu raring latest again and the bug is still bugging me ;).

Please let me know if I can provide more info so the bug can be fixed.

Comment 18 Thilo Cestonaro 2013-06-04 06:39:06 UTC

latest raring with

(ubuntu package versions)

kernel                    - 3.8.0-23-generic
mesa                      - 9.1.1-0ubuntu3
xserver-xorg-video-radeon - 7.1.0-0ubuntu2
xserver-xorg              - 7.7+1ubuntu4

still showing the same problem.

Comment 19 Thilo Cestonaro 2013-06-28 05:55:05 UTC

updated to saucy yesterday. Still not working.

Comment 20 Thilo Cestonaro 2013-07-10 05:15:02 UTC
Latest saucy. kernel 3.10.0-2. still seeing these glitches.

Comment 21 Thilo Cestonaro 2013-09-13 06:34:36 UTC
Latest Saucy. Still no luck :(
Kernel: 3.11.0-7-generic

Greetings Thilo
Comment 22 Alex Deucher 2013-10-01 23:26:20 UTC
Created attachment 86939 [details] [review]
possible fix

Does this patch fix the issue?
Comment 23 Thilo Cestonaro 2013-10-03 07:16:20 UTC
Sadly no. Unity still is flickering and has that triangle kind of display errors.


Comment 24 Christopher M. Penalver 2016-02-26 03:19:35 UTC
Thilo Cestonaro, Ubuntu Saucy reached EOL on July 17, 2014. For more on this, please see https://wiki.ubuntu.com/Releases.

If this is reproducible in a supported release, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.