Bug 6044 - Memory leak in mga driver - glGenTextures
Summary: Memory leak in mga driver - glGenTextures
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/MGA (show other bugs)
Version: 6.4
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL: http://www.descent2.de/d2x.html
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-26 02:46 UTC by Kimmo Sundqvist
Modified: 2006-11-26 01:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kimmo Sundqvist 2006-02-26 02:46:44 UTC
Running the d2x-xl game, either one compiled from source or a binary version. 
When in menus, the heap size (as displayed by cat /proc/pid-of-the-game/smaps)
grows with speed ranging from half megabyte to more than 20 megabytes per second.

Building a d2x-gl binary with debug enabled, the problem has been located to a
call to glGenTextures.  The problem happens not every but almost every time this
function is called in the menus.

http://www.descentbb.net/viewtopic.php?t=8983&postdays=0&postorder=asc&start=55

I'm not experienced enough to see if the game misuses the call.  Also, I have
some reasons to assume the problem is limited to the mga driver.  It happens
with a G400 MAX card, and a 16MB Millennium G200 card.  It happens with Gentoo's
unofficial monolithic Xorg 6.9.0 and Gentoo's modular Xorg 7.0.0-r1
Comment 1 ajax at nwnk dot net 2006-03-12 08:35:24 UTC
GenTextures happens in the GL driver, not the X driver.
Comment 2 Tilman Sauerbeck 2006-11-26 01:40:05 UTC
Fixed.


bug/show.html.tmpl processed on Sep 29, 2016 at 00:01:31.
(provided by the Example extension).