Bug 60447 - [ivb, steam] Counter-Strike: Source rendering glitches
[ivb, steam] Counter-Strike: Source rendering glitches
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
Other All
: high normal
Assigned To: Ian Romanick
Depends on:
  Show dependency treegraph
Reported: 2013-02-07 22:06 UTC by John Drinkwater
Modified: 2014-10-23 06:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description John Drinkwater 2013-02-07 22:06:22 UTC
Vertex(?) corruption or something like it running CS:S.

Don’t have the chipset myself so I cannot give further information, but I can pass this report on from steam’s issue tracker.
Comment 1 João Vitor 2013-02-07 23:59:46 UTC
I can reproduce this bug, can I help?
Comment 2 Eric Anholt 2013-02-08 18:30:07 UTC
If you could capture the bug in an apitrace trace, that would help the debugging.
Comment 3 Eric Anholt 2013-02-12 23:37:08 UTC
Also, there is some thought that this may be fixed as of:

commit 09fbc298283b41cf3f25d75842a6d8ab4952dca1
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Feb 2 12:46:49 2013 -0800

    i965: Fix the SF Vertex URB Read Length calculation for Sandybridge.
Comment 4 João Vitor 2013-02-14 21:52:43 UTC
I tried running the game with apitrace but the trace is not generated, it works fine with glxgears.

I tried also with --api=egl and --api=gl.
Comment 5 Eric Anholt 2013-02-14 23:42:02 UTC
Looks great for me on a current kernel and Mesa.  If you could upgrade to Mesa from git (and probably your kernel too -- it seems like they're always finding new workaround registers to set) and try again, that would be great.  Note of course that the app is 32-bit, so you'll need to be sure to build/install that way.
Comment 6 Eric Anholt 2013-02-15 20:24:15 UTC
OK, we've now tested this on the machine that Valve reproduced it on before, and it's not happening any more.  Current theory is that it may have been on the app side and an update has been pushed out.  I'd love to hear if you can still reproduce the problem after app updates.
Comment 7 João Vitor 2013-02-16 21:16:33 UTC
Steps to reproduce the bug on CS:S

1 - Create a server
2 - Select de_dust2, no bots
3 - Start the game
4 - Select Terrorist (the glitches depends on the current weapon)
5 - Select any model

The glitches occur on the default pistol and knife on the Terrorist team (does not occur while holding the bomb).

Maybe you tested it again, but selected the CT team, where the bug does not occur.

I'm testing with Ubuntu 12.10 (x64), with everything updated (by the "Software Updater").

Steam is updated and also is the game.

I don't want to mess too much with my system so I won't update my mesa and kernel manually.
People depend on this machine to be working.
Comment 8 Gustavo 2013-02-20 06:24:45 UTC
I can reproduced with an updated Kubuntu 12.10 64 Bits with an HD 4000.
I noticed that enabling effects increments the amount and frequency of this glitches, But if the texture quality is set to the lowest setting, then, no matter what the other settings are, the glitches will not appear.
Comment 9 Eric Anholt 2013-05-29 20:50:57 UTC
Yeah, works fine here with mesa master following that set of instructions (de_dust2, terrorist (model #4)), walked with the pistol out far enough to plant the bomb then wander around with the pistol until the bomb went off.  I assume it's frequent enough I should have seen it in that time.

Video settings were widescreen 1440x900 fullscreen, everything on "High" that had that as an option, highest HDR setting, water reflection enabled at the middle level.

I also tried going back to mesa 9.0, and I even tried mesa 9 without the fix I mentioned.  Everything's fine.

Please update your kernel and Mesa to the latest (not just what's in ubuntu) and see how things are.
Comment 10 Tapani Pälli 2013-07-31 06:41:34 UTC
I can reproduce this on IVB running Ubuntu 13.04 and Mesa 9.1.3 (from Ubuntu repo). There are occational blinks (very quick) of artifacts when texture resolution and HDR settings are high. Running steam against git ~master (e847b5a) makes these artifacts go away.
Comment 11 Tapani Pälli 2014-10-23 06:37:27 UTC
As I stated (last summer) the issues have been fixed in Mesa master. Steam OS and distros are using already Mesa 10.x, please file a new bug if issues continue.