Bug 62449 - --log-level=debug not working properly
Summary: --log-level=debug not working properly
Status: RESOLVED FIXED
Alias: None
Product: Zeitgeist
Classification: Unclassified
Component: Engine (show other bugs)
Version: 0.9.x
Hardware: Other All
: medium normal
Assignee: zeitgeist-bugs@lists.freedesktop.org
QA Contact: zeitgeist-bugs@lists.freedesktop.org
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-17 21:59 UTC by Seif Lotfy
Modified: 2013-03-19 01:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Seif Lotfy 2013-03-17 21:59:56 UTC
When running zeitgeist with the argument --log-level=debug it is expected that it
prints out the query plan and explanation. This is not the case.

AFAICT the problem is that EXPLAIN_QUERIES not respected by db-reader.vala and sql.vala although zeitgeist is configured with --enable-explain-queries

the config.log says
...
EXPLAIN_QUERIES_FALSE='#'
EXPLAIN_QUERIES_TRUE=''
...
Comment 1 Seif Lotfy 2013-03-19 01:05:39 UTC
Rico fixed it in master :D


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.