Bug 65477 - Error 404 after a few syncs
Summary: Error 404 after a few syncs
Status: RESOLVED NOTOURBUG
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: 1.3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-06 19:12 UTC by Daniel
Modified: 2013-08-09 18:01 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Daniel 2013-06-06 19:12:07 UTC
Since a few weeks I have the following problem with my provider Memotoo:
After a refresh-from-server I sync a few times, then suddenly an error 404 object not found occures. The status of the sync afterwards is 10400. The next sync wants do do a slow-sync, since I have forbidden this it aborts. Then I have do do a refresh-from-server again. After that I can sync a few times (with data changes, the are always OK), and then the 404 error is here again.

Until somewhere in April this was never the case. I synced for months with memotoo without this problem.

What is the cause? I use version 1.3.2 since months on Ubuntu 12.04.
Comment 1 Patrick Ohly 2013-06-07 15:13:43 UTC
> What is the cause? I use version 1.3.2 since months on Ubuntu 12.04.

So 1.3.2 was working fine for a while and then later the problem started to occur? That would point towards a change on the server.

Either way, without further information about where the 404 error occurs it's not possible to root cause the issue. It's not a known problem.

Can you perhaps attach a syncevolution-log.html file that contains the problem?

If it contains private information, then you can send it to me ("patrick.ohly at gmx.de") directly and I'll treat it confidentially.
Comment 2 Daniel 2013-06-10 13:41:12 UTC
I have sent the syncevolution-log.html of the sync that ends with error 10400 to your gmx account. The next sync will force a slow-sync and stop, because I have forbidden slow-syncs. Do you also need the log from this next sync?
Comment 3 Patrick Ohly 2013-06-10 14:41:57 UTC
(In reply to comment #2)
> I have sent the syncevolution-log.html of the sync that ends with error
> 10400 to your gmx account. The next sync will force a slow-sync and stop,
> because I have forbidden slow-syncs. Do you also need the log from this next
> sync?

No, the error is in the log that you sent. It looks like a SyncML protocol violation by the Memotoo server:

[2013-06-09 18:38:07.564] 'processCmd' - Processing incoming command, Cmd=Sync, IncomingMsgID=4, CmdID=2 [--][++] [->end] [->enclosing]

    [2013-06-09 18:38:07.565] Created command 'Status' (outgoing)
    [2013-06-09 18:38:07.565] Processing Sync, Source='note', Target='./memo'
    [2013-06-09 18:38:07.565] Sync command not allowed outside of sync phase (-> 403)
    –
    [2013-06-09 18:38:07.565] 'SessionAbort' - Aborting Session, Status=400, ProblemSource=LOCAL [--][++] [->end] [->enclosing]
        [2013-06-09 18:38:07.565] WARNING: Aborting Session with Reason Status 400 (LOCAL problem) ***

My guess is that you can work around this by limiting syncs to just one source at a time:
syncevolution memotoo addressbook
syncevolution memotoo calendar
syncevolution memotoo todo
syncevolution memotoo memo

I'll contact the Memotoo admin and see whether he has an opinion about this.
Comment 4 Daniel 2013-06-29 20:23:23 UTC
I have deactivated the synchronisation from memotoo with evernote and now the problem with syncevolution is gone.
Comment 5 Daniel 2013-08-09 15:18:50 UTC
Until today still without sync to evernote all is ok with syncevolution. I think this bug could be closed because Thomas at memotoo has to do something.
Comment 6 Patrick Ohly 2013-08-09 18:01:39 UTC
Thanks for the reminder. Yes, let's close it here.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.