Bug 65678 - xf86-video-modesetting-0.7.0 and 0.8.0 - no signal when i try to rotate screen
Summary: xf86-video-modesetting-0.7.0 and 0.8.0 - no signal when i try to rotate screen
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/modesetting (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-12 14:49 UTC by Mikhail
Modified: 2018-12-13 18:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Mikhail 2013-06-12 14:49:44 UTC
xf86-video-modesetting-0.7.0 and 0.8.0 - no signal when i try to rotate screen


xrandr -o left


no errors o warnings in log
Comment 1 Mikhail 2013-06-12 14:58:48 UTC
video: gma 3650 (atom 2700)
Comment 2 Jochen Keil 2013-11-02 11:46:09 UTC
Hi,

I can confirm this bug. I'm using a DisplayLink device (D-195) which works reasonable fine in with "normal" rotation, but when I try to rotate the output the monitor blanks.

Since the fbdev driver for this allows Rotation, I think it is a problem with the modesetting driver. As far as I can tell from looking at the source, I think rotation is not even implemented (RR_Rotation_{90,270} are completely missing). However, I don't know nothing about KMS or xorg driver architecture in general, so I might be wrong here.

Will this ever be fixed? It would be good to get an idea if/when this is going to happen, because without rotation the device is useless for me.

Thanks!
Comment 3 GitLab Migration User 2018-12-13 18:10:15 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/39.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.