Bug 66004 - build failed with "--enable-stats"
Summary: build failed with "--enable-stats"
Status: RESOLVED FIXED
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: 1.5
Hardware: Other All
: medium normal
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-21 09:12 UTC by Chengwei Yang
Modified: 2013-06-24 12:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
[PATCH] Fix build failure if build with "--enable-stats" (1.13 KB, patch)
2013-06-21 09:14 UTC, Chengwei Yang
Details | Splinter Review

Description Chengwei Yang 2013-06-21 09:12:52 UTC
build failed with "--enable-stats" due to use void function as bool function like below

if (!_dbus_list_get_stats (&in_use, &in_free_list, &allocated) ||
...
Comment 1 Chengwei Yang 2013-06-21 09:14:50 UTC
Created attachment 81157 [details] [review]
[PATCH] Fix build failure if build with "--enable-stats"
Comment 2 Simon McVittie 2013-06-24 12:09:33 UTC
Fixed in git for 1.7.6, thanks. Regression in master, no backport needed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.