Bug 6624 - AIGLX reports not supported visuals
AIGLX reports not supported visuals
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: libglx
XOrg git
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
: 8477 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 09:13 UTC by Diego
Modified: 2010-02-18 04:55 UTC (History)
22 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log (44.35 KB, text/plain)
2006-04-17 21:57 UTC, Diego
no flags Details
xorg.conf (3.14 KB, text/plain)
2006-04-17 21:57 UTC, Diego
no flags Details
xorg log for 855GM chipset, i810. (74.45 KB, text/plain)
2006-04-20 04:18 UTC, Khashayar Naderehvandi
no flags Details
xorg log (64.97 KB, text/plain)
2006-12-24 21:40 UTC, Sérgio M. Basto
no flags Details
xorg.conf Radeon Mobility M7 LW [7500] (803 bytes, text/plain)
2007-03-19 12:15 UTC, Sven Pedersen
no flags Details
xorg.log Radeon Mobility 7500, i845 chipset (42.69 KB, text/plain)
2007-03-19 12:26 UTC, Sven Pedersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego 2006-04-17 09:13:03 UTC
i'm running X on a 

VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]

Upon startup the X log contains this:

(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32

glxgears, also reports this:
libGL warning: 3D driver claims to not support visual 0x4b
Comment 1 Erik Andren 2006-04-17 18:08:56 UTC
Please post your xorg.conf and your xorg.log
Comment 2 Diego 2006-04-17 21:57:16 UTC
Created attachment 5345 [details]
Xorg.log
Comment 3 Diego 2006-04-17 21:57:34 UTC
Created attachment 5346 [details]
xorg.conf
Comment 4 Diego 2006-04-17 21:58:32 UTC
this is what glxinfo says about the visuals available:

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x4b 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
Comment 5 Khashayar Naderehvandi 2006-04-20 04:18:14 UTC
Created attachment 5384 [details]
xorg log for 855GM chipset, i810.
Comment 6 Khashayar Naderehvandi 2006-04-20 04:21:04 UTC
(In reply to comment #5)
> Created an attachment (id=5384) [edit]
> xorg log for 855GM chipset, i810.
> 

Hm, my post disappeared. Anyway, I have the exact same issue on an intel 855GM,
using i810 1.6.0, and mesa 6.5. I've attached the xorg log file. If I need to
attach anything else, please do tell. 
Comment 7 Khashayar Naderehvandi 2006-04-20 23:28:12 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Created an attachment (id=5384) [edit] [edit]
> > xorg log for 855GM chipset, i810.
> > 
> 
> Hm, my post disappeared. Anyway, I have the exact same issue on an intel 855GM,
> using i810 1.6.0, and mesa 6.5. I've attached the xorg log file. If I need to
> attach anything else, please do tell. 


After upgrading mesa to CVS today, the amount of warnings shrunk to only 1:

 glxinfo | grep render
libGL warning: 3D driver claims to not support visual 0x4b
Mesa: CPU vendor: GenuineIntel
Mesa: CPU name:         Intel(R) Pentium(R) M processor 1.20GHz
Mesa: MMX cpu detected.
Mesa: SSE cpu detected.
Mesa: Not testing OS support for SSE, leaving enabled.
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 852GM/855GM 20050225 x86/MMX/SSE2
Comment 8 Erik Andren 2006-04-21 00:40:57 UTC
I can confirm comment #7, I also get one libGL warning. This is with a radeon
7500 mobility.

libGL warning: 3D driver claims to not support visual 0x4b
Mesa: CPU vendor: GenuineIntel
Mesa: CPU name:    Mobile Intel(R) Pentium(R) 4 - M CPU 2.00GHz
Mesa: MMX cpu detected.
Mesa: SSE cpu detected.
Mesa: Not testing OS support for SSE, leaving enabled.
direct rendering: Yes
OpenGL renderer string: Mesa DRI Radeon 20060327 AGP 4x x86/MMX/SSE2 TCL
erik@Ross154 /tmp/driver/xf86-video-ati $
Comment 9 Diego 2006-04-21 21:55:57 UTC
maybe this is a MESA or DRM bug itself, because glxgears has this error ...

I'm going to fill it into the MESA tree to see what the developers say.
Comment 10 Erik Andren 2006-04-22 15:53:21 UTC
*** Bug 6689 has been marked as a duplicate of this bug. ***
Comment 11 Angka H. K. 2006-04-23 21:16:01 UTC
My freebsd box also produce the same result, may be it's not specific to some
os. I use freebsd 7.0, Mesa and DRM from lates CVS.
Comment 12 Diego 2006-04-28 03:26:50 UTC
ping? so far noone from the XOrg or Mesa/DRI team has answered anything.
Comment 13 Dirk-Jan Heijs 2006-05-16 01:18:09 UTC
I have the same problem with my Radeon r200 on an Asus P4P800.
Comment 14 Samuli Suominen 2006-06-05 09:27:37 UTC
I'm using r200 (9200 PRO) with xorg-server, libdrm, mesa, xf86-video-ati CVS
from today, rest of X.org is from Gentoo Portage.

Used this option, Option "AIGLX" "false" to get rid of those messages in
Xorg.0.log (as I don't need AIGLX yet) but..

libGL warning: 3D driver claims to not support visual 0x4b

..remains in glxgears/glxinfo.
Comment 15 Patrick McLean 2006-06-20 11:41:38 UTC
I am hitting this on my laptop, with the i915 driver (the card is an i855GM),
running kernel 2.6.17

here's the full output of glxinfo with LIBGL_DEBUG=verbose, if there is any
other info you need, let me know.

 # DISPLAY=:0 LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 1.5.1 i915 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/tls/i915_dri.so
libGL: OpenDriver: trying /usr/lib/dri/i915_dri.so
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
libGL warning: 3D driver claims to not support visual 0x23
libGL warning: 3D driver claims to not support visual 0x25
libGL warning: 3D driver claims to not support visual 0x27
libGL warning: 3D driver claims to not support visual 0x29
libGL warning: 3D driver claims to not support visual 0x2b
libGL warning: 3D driver claims to not support visual 0x2d
libGL warning: 3D driver claims to not support visual 0x2f
libGL warning: 3D driver claims to not support visual 0x31
libGL error:
Can't open configuration file /etc/drirc: No such file or directory.
libGL error:
Can't open configuration file /root/.drirc: No such file or directory.
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_video_sync, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 852GM/855GM 20050225 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 6.5
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_equation_separate,
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array,
    GL_EXT_convolution, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_histogram, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
    GL_EXT_vertex_array, GL_3DFX_texture_compression_FXT1,
    GL_APPLE_client_storage, GL_APPLE_packed_pixels,
    GL_ATI_blend_equation_separate, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos,
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1,
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
Comment 16 Sebastian Bergmann 2006-06-27 06:39:48 UTC
Same problem here with Gentoo Linux, X.org 7.1, and the i810 driver on an
ThinkPad X60s notebook.
Comment 17 Sebastian Bergmann 2006-06-29 00:32:44 UTC
After updating to the current MESA CVS (from Hanno Böck's Gentoo Overlay) the
problem is gone.
Comment 18 Michel Dänzer 2006-08-26 05:40:10 UTC
The server side warnings seem fixed. For the client side, see bug 6689.
Comment 19 Michel Dänzer 2006-08-31 01:46:06 UTC
Actually, I'm still seeing this with the radeon/r200 drivers and more or less
current development snapshots. Needs investigation.

That said, it seems mostly if not completely cosmetic.
Comment 20 Joachim Frieben 2006-08-31 01:57:52 UTC
(In reply to comment #19)
Right, I still see this for my Radeon 7200 (R100), too. "X", etc. are almost up
to date ("Fedora rawhide"). Moreover, the "savage" driver is affected, too ("IBM
ThinkPad T23" sporting a "SuperSavage IX/C"). For the latter, "Xorg.0.log" reports:

"(WW) AIGLX: 3D driver claims to not support visual 0x23
 (WW) AIGLX: 3D driver claims to not support visual 0x24
 (WW) AIGLX: 3D driver claims to not support visual 0x25
 (WW) AIGLX: 3D driver claims to not support visual 0x26
 (WW) AIGLX: 3D driver claims to not support visual 0x27
 (WW) AIGLX: 3D driver claims to not support visual 0x28
 (WW) AIGLX: 3D driver claims to not support visual 0x29
 (WW) AIGLX: 3D driver claims to not support visual 0x2a
 (WW) AIGLX: 3D driver claims to not support visual 0x2b
 (WW) AIGLX: 3D driver claims to not support visual 0x2c
 (WW) AIGLX: 3D driver claims to not support visual 0x2d
 (WW) AIGLX: 3D driver claims to not support visual 0x2e
 (WW) AIGLX: 3D driver claims to not support visual 0x2f
 (WW) AIGLX: 3D driver claims to not support visual 0x30
 (WW) AIGLX: 3D driver claims to not support visual 0x31
 (WW) AIGLX: 3D driver claims to not support visual 0x32".

After launching "glxgears", a "Mesa" warning is spawned to the shell:

 "libGL warning: 3D driver claims to not support visual 0x4b".
Comment 21 Michel Dänzer 2006-08-31 02:02:31 UTC
Please don't clutter up this report with more of the same information that's
already here. Thanks.
Comment 22 Dark Shadow 2006-09-21 18:16:39 UTC
(In reply to comment #19)
> Actually, I'm still seeing this with the radeon/r200 drivers and more or less
> current development snapshots. Needs investigation.
> 
> That said, it seems mostly if not completely cosmetic.

The `visual 0x4b' warnings disappear when disabling the composite extension
(radeon) in xorg.conf. Or the other way round: They only appear when enabling
the composite extension ;-)
Comment 23 Michel Dänzer 2006-10-02 00:24:42 UTC
*** Bug 8477 has been marked as a duplicate of this bug. ***
Comment 24 Mark M. Ito 2006-12-08 08:35:19 UTC
The post mention that the bug is fixed on the CVS tree. Was the fixed included
in version 6.5.1? I am getting a form of it with this version, from a Fedora rpm.

Comment 25 Sérgio M. Basto 2006-12-24 21:40:07 UTC
Created attachment 8208 [details]
xorg log

I tryed with libdrm-2.3.0-1.fc6 Mesa6.5.2 and (II) Module i810: vendor="X.Org
Foundation"
    compiled for 7.1.1, module version = 1.7.3

and nothing new
Comment 26 Sven Pedersen 2007-03-19 12:15:25 UTC
Created attachment 9222 [details]
xorg.conf Radeon Mobility M7 LW [7500]

On this machine a hard freeze happens immediately after the message indicating this bug appears.
Comment 27 Sven Pedersen 2007-03-19 12:26:10 UTC
Created attachment 9224 [details]
xorg.log Radeon Mobility 7500, i845 chipset

Sorry, I'm just learning to use Bugzilla. I wanted to give more info.

I'm using a ThinkPad T30, which has the Intel 845 (82845) chipset and a Radeon Mobility M7 LW (normally called 7500). I'm running the newly released RedHat Enterprise 5, which is based on Fedora Core 6. It has OpenGL 1.3 (Mesa 6.5.1) and Xorg 7.1 on Linux kernel 2.6.18 (heavily patched following RedHat tradition to be more like 2.6.19 or so).

I first noticed the crash bug when I tried to use the Fedora Core 6 livecd a few months back, but thought it was just a buggy distro.
Comment 28 Michel Dänzer 2007-03-19 23:08:51 UTC
(In reply to comment #26)
> 
> On this machine a hard freeze happens immediately after the message indicating
> this bug appears.

That can't be directly related to these messages. Please find a bug about a similar freeze or file a new one.
Comment 29 Juan Pablo Salazar Bertin 2007-08-15 15:00:30 UTC
I think this is being fixed in bug #6689.

*** This bug has been marked as a duplicate of bug 6689 ***
Comment 30 Michel Dänzer 2007-08-16 01:58:58 UTC
This is very unlikely a duplicate:

* The list of visuals warned about is different between libGL and the X server.
* The code in question is different between them as well.

That said, it's quite possibly a similar issue as bug 6689, so maybe the lessons learned there can be applied here.
Comment 31 Michel Dänzer 2008-11-13 01:30:20 UTC
This shouldn't happen anymore with current xserver.
Comment 32 Anonymous Helper 2009-02-01 16:24:24 UTC
(Sorry for logging in anonymous. I don’t want to create an account to drop a singe message.)

This is still not fixed in the current xserver. At least the closed one from ATi.

I have version 8.561 installed right now, and i still get the errors:

(WW) AIGLX: 3D driver claims to not support visual 0x23
                             ⋮
(WW) AIGLX: 3D driver claims to not support visual 0x72