Bug 70472 - error code from SyncEvolution fatal error (local, status 10500): calendar: storing new item: Cannot create calendar object: The request failed schema validation: The 'http://schemas.microsoft.com/exchange/services/2006/types:EmailAddress' element is inval
Summary: error code from SyncEvolution fatal error (local, status 10500): calendar: st...
Status: RESOLVED FIXED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: 1.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-15 04:37 UTC by Darren
Modified: 2014-02-14 10:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Log of error (356.62 KB, text/html)
2013-10-15 04:37 UTC, Darren
Details
Log after running "syncevolution loglevel=4 --sync refresh-from-server memotoo calendar" (1.56 MB, text/html)
2013-10-15 12:14 UTC, Darren
Details

Description Darren 2013-10-15 04:37:06 UTC
Created attachment 87642 [details]
Log of error

Binaries from Debian Sid
Evolution ver 3.8-5 (Debian Jessie)
Synchronisation with memotoo


Tried to refresh from server by "syncevolution --sync refresh-from-server memotoo calendar

Locked in a loop - keeps showing the following error:

[ERROR] error code from SyncEvolution fatal error (local, status 10500): calendar: storing new item: Cannot create calendar object: The request failed schema validation: The 'http://schemas.microsoft.com/exchange/services/2006/types:EmailAddress' element is invalid - The value '' is invalid according to its datatype 'http://schemas.microsoft.com/exchange/services/2006/types:NonEmptyStringType' - The actual length is less than the MinLength value.

Had to abort the synchronisation.

This just started couple of days ago.
Comment 1 Patrick Ohly 2013-10-15 06:20:20 UTC
Where do you store the data in EDS? It looks like you are (intentionally or unintentionally) using an EDS backend which talks to Exchange.

If this is intentional, then we need to figure out what it complains about. Can you run "syncevolution loglevel=4 --sync refresh-from-server memotoo calendar" and then look at one specific, simple example that triggers the error? The output should contain "generated" data that then gets sent to EDS. It'll be interesting to see whether there is an empty email address involved.

If this is unintentional, then ordering of your calendars changed such that the default calendar is no longer your local one. What does "syncevolution --print-databases" say?

You can override the implicit default with
  syncevolution --configure database=... @default calendar
Comment 2 Darren 2013-10-15 12:14:20 UTC
Created attachment 87667 [details]
Log after running "syncevolution loglevel=4 --sync refresh-from-server memotoo calendar"

This is redacted else it would be waaayyy too long.
Comment 3 Patrick Ohly 2013-10-15 12:35:04 UTC
(In reply to comment #2)
> Created attachment 87667 [details]
> Log after running "syncevolution loglevel=4 --sync refresh-from-server
> memotoo calendar"

This shows that even very simply events fail to be stored by EDS, which is most likely a bug in EDS. It should be possible to reproduce that without syncing like this:

cat >/tmp/test.ics <<EOF
BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Synthesis AG//NONSGML SyncML Engine V3.4.0.41//EN
BEGIN:VEVENT
LAST-MODIFIED:20130916T131237
DTSTAMP:20131015T094707Z
CLASS:PUBLIC
SUMMARY:Philippine Madrigal Singers
LOCATION:SOTA Concert hall\, 1 Zubir Said Drive\, Singapore 227968
DTSTART:20131104T190000
DTEND:20131104T210000
BEGIN:VALARM
TRIGGER;VALUE=DURATION:-P1D
ACTION:DISPLAY
END:VALARM
END:VEVENT
END:VCALENDAR
EOF

syncevolution --import /tmp/test.ics \
              backend=evolution-calendar \
              database=...

where the value of "database" comes from "--print-databases" and matches the database that you are using for syncing.

Does this fail as expected? Then please file a bug with Debian for their version of EDS. You might also try upstream EDS, but it is less likely that they'll support 3.8.

But just to be sure (as you didn't answer that part of the question) - it is intentional that you try to store in Exchange?
Comment 4 Darren 2013-10-15 12:46:18 UTC
My apologies - yes, I was trying to get everything synchronised up with Exchange.  Used to work until a couple of days ago.  Could well be an EDS issue. C'est la vie... will have to figure out a workaround for now...
Comment 5 Patrick Ohly 2014-02-14 10:39:19 UTC
I'm closing this as it doesn't seem to be caused by SyncEvolution.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.