Bug 70773 - Improper Filename for the imported Pictures
Summary: Improper Filename for the imported Pictures
Status: RESOLVED NOTABUG
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: PIM Manager (show other bugs)
Version: 1.3.99.3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-22 17:54 UTC by Eugenio Parodi
Modified: 2014-02-14 10:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Eugenio Parodi 2013-10-22 17:54:21 UTC
Precondition:
	peer(phone or vcards) has contacts with pictures 

Action:
	sync the peer then try to read photo 

Expected behavior:
	peer is synced and photo is the same as in phone (vcards)

Observed behavior:
	syncevolution creates photo file after peer sync but file file name has encoding error

photo field in contact :
	file:///xxx/xxx/xxx/xxx/.data/evolution/addressbook/pim-manager-00001/photos/pas_id_5256B5B000000006_photo-file0.image%252Fjpeg

file name :
	pas_id_5256B5B000000006_photo-file0.image%252Fjpeg

proper file name should be pas_id_5256B5B000000006_photo-file0.jpeg
Comment 1 Patrick Ohly 2013-10-22 18:59:15 UTC
Just to be sure I understand, the file name as it stands today is usable, isn't it?

It's just not as nice as it could be, because of the extra escaping of the running number?
Comment 2 Eugenio Parodi 2013-10-23 12:00:54 UTC
Yes It is usable but the double quotation may lead to implementation errors.
This is anyway minor issue.
At least we should provide some information on how to decode it.
Comment 3 Patrick Ohly 2013-10-23 12:55:38 UTC
(In reply to comment #2)
> Yes It is usable but the double quotation may lead to implementation errors.
> This is anyway minor issue.
> At least we should provide some information on how to decode it.

The PHOTO value is an URL. That already defines how to decode it, there's nothing special about it.

In particular, you cannot just strip a the file:// prefix and use the remainder as file name. One has to do URL decoding. Whether encoding is really used is a different matter. The code has to assume that it is, and from that perspective it is actually good to have it tested.

Obviously it is less nice for testers and developers.

Do we agree to treat this as a low priority feature request for EDS ("avoid quoting of number when creating photos") that can be deferred?
Comment 4 Eugenio Parodi 2013-10-23 13:19:05 UTC
Ok, I was not aware that EDS was responsible of this.
We can defer it and open an EDS minor request.
Comment 5 Patrick Ohly 2014-02-14 10:39:47 UTC
Let's track elsewhere. Closing it here.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.