Bug 72212 - Changing display mode while opening audio leaves audio unusable
Summary: Changing display mode while opening audio leaves audio unusable
Status: CLOSED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-02 04:28 UTC by Lauri Mylläri
Modified: 2017-07-24 22:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
kernel log from failed playback attempt (222.17 KB, text/plain)
2013-12-02 04:28 UTC, Lauri Mylläri
no flags Details

Description Lauri Mylläri 2013-12-02 04:28:29 UTC
Created attachment 90072 [details]
kernel log from failed playback attempt

I am using xbmc on Haswell to play a video with DTS-HD/MA audio. If resolution matching is enabled, sometimes audio playback fails with input/output error, and any further attempt to open the audio device fails.

If I disable resolution matching, I don't encounter this issue and HBR audio works fine.

I tried reproducing the issue with speaker-test and xrandr, but could not trigger it. My guess is that it is very timing sensitive, and xbmc happens to time the mode change and audio init just right.

I built a kernel with verbose sound debugging, and booted with drm.debug=0x0e. I am attaching a log from a failed playback attempt. My kernel includes some upstream patches, see linux-992.* in https://github.com/laurimyllari/OpenELEC.tv/tree/77faefac8ef51d9434a918ba4bb12deddaa9e416/packages/linux/patches/3.12.1

I have also tried using 3.13-rc1.

Is it obvious from the log what's happening? If not, what would be the best way to provide useful information?

(The log is a bit verbose, but some points of interest may be at 81.199631 where ELD is not yet available, 81.499301 retry after 300ms, 81.571388 fifo underrun and 91.489083 playback write error)
Comment 1 Lauri Mylläri 2013-12-02 05:08:39 UTC
I forgot to mention that I've only seen this with HBR audio.
Comment 2 Daniel Vetter 2013-12-03 15:54:07 UTC
Since the audio side of things fail I think it's better to file this as an upstream kernel bug against ALSA on bugzilla.kernel.org.

3.13-rc1 should have all the latest fixes for the gfx side of things. It sounds like the audio driver doesn't correctly update audio modes when the display config changes ...

But maybe test drm-intel-nightly from http://cgit.freedesktop.org/~danvet/drm-intel/ to make sure.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.