Bug 72795 - [HSW dp mst] Dell dock DVI knocks out DP when unplugged.
Summary: [HSW dp mst] Dell dock DVI knocks out DP when unplugged.
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium enhancement
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 76435 80187 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-17 15:20 UTC by Ben Whitten
Modified: 2017-07-24 22:56 UTC (History)
38 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg of display knockout (34.32 KB, application/x-tar)
2013-12-17 15:20 UTC, Ben Whitten
no flags Details
Xorg.log (37.94 KB, text/plain)
2014-03-07 17:16 UTC, oss+freedesktop
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Whitten 2013-12-17 15:20:17 UTC
Created attachment 90880 [details]
dmesg of display knockout

I have a Dell Latitude E7440 connected to a Dell E-Port WV7MW dock, which feeds two Dell P2214H monitors, one using DP on the dock the other using DVI.

The DVI screen suffers corruption from time to time, pixels get shifted then it blinks off then comes back and is fine for ages, I have also noticed corruption while unplugging in the form of lots of red pixels, might not be relevant to this.

Both screens are mirrored and I am unable to set them seperatly from arandr, whats identified as DP2 always gets output on both screens.
I have also found that while unplugging the docks display port and re plugging results in expected screen doing off and back on, however unplugging the docks DVI results in both screens being knocked out and replugging has no effect both monitors stay off, even with replugging the DP. Logging out and loging back in fixes it.

Attached is a dmesg with debug=14 of starting up, unplugging DP, replugging, unplugging DVI, replugging, and then a relog.
Comment 1 Chris Wilson 2013-12-17 17:12:35 UTC
Hmm, the dock only presents a DP link, so I guess it is acting as a MST hub.
Comment 2 Damien Lespiau 2013-12-17 21:35:27 UTC
Let's re-classify it as an enhancement then, DP MST is a fair amount of work.
Comment 3 Ferry Huberts 2014-02-12 11:43:11 UTC
I'd like to request DP MST for my Tinkpad T440s + Ultra dock combination.
After upgrading the firmware of the dock, it appears that one 1 display works.

(coming in from bug 71267)
Comment 4 Stefan 2014-02-12 13:48:20 UTC
I would also like DP MST support for my Tinkpad T440s + Ultra dock.

Is this planned any time soon? Thanks for any updates.
Comment 5 Ferry Huberts 2014-02-12 13:59:54 UTC
(In reply to comment #3)
> I'd like to request DP MST for my Tinkpad T440s + Ultra dock combination.
> After upgrading the firmware of the dock, it appears that one 1 display

only 1 DP display instead if the 2 DP displays.

The DP displays are connected to the dock

> works.
> 
> (coming in from bug 71267)
Comment 6 Georg Pichler 2014-02-12 15:05:44 UTC
I would also very much appreciate DP MST support for the Lenovo Thinkpad T440 + Ultradock combination (also coming in from bug 71267).

When there are any updates happening, is this the place where they'll be posted?
Comment 7 Jani Nikula 2014-02-12 15:16:35 UTC
(In reply to comment #6)
> When there are any updates happening, is this the place where they'll be
> posted?

Knowing there are people here with the hardware and apparently willingness to test any support we add out in the real world, I would presume so yes. As to plans or schedules, there's unfortunately nothing further I can say.
Comment 8 Bernhard 2014-02-12 19:53:00 UTC
I'd like to see DP MST HUB support as well (ThinkPad Ultra Dock). If someone cares, here is a little bounty: http://freedomsponsors.org/core/issue/444/hsw-mst-dell-dock-dvi-knocks-out-dp-when-unplugged
Comment 9 Jake 2014-02-14 08:31:13 UTC
Another vote for DP MST support (Lenovo Thinkpad T440s + Ultradock)
Comment 10 Libor Jonát 2014-02-17 13:03:08 UTC
I vote for DP MST support as well (Lenovo Thinkpad x240 + Ultradock)
If there will be some patches i can test them.
Comment 11 frederik 2014-03-06 20:22:14 UTC
+1 for DP MST
Comment 12 oss+freedesktop 2014-03-07 17:16:13 UTC
I also have a Dell Latitude E7440, with two 1600x1200 monitors connected via Display Port to a Dell PR02X dock. I can not get both monitors to work in dual head. They do work in mirror mode. It seems as if only one Display Port is visible to the operating system. The 3840x1200 resolution on DP1 works as well, the image is then stretched over both monitors.

Previously, I had a Dell Latitude E6410 in the same dock with the same two monitors, using the nouveau driver. That worked flawlessly. I still have that laptop around for a few more days. If required, I can provide more info on that one.

The relevant output of xrandr, lspci and dmesg can be found below. My Xorg.log file will follow in attachment.

$ uname -a
Linux something 3.13.5-1-ARCH #1 SMP PREEMPT Sun Feb 23 00:25:24 CET 2014 x86_64 GNU/Linux

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

$ xrandr 
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 32767 x 32767
eDP1 connected (normal left inverted right x axis y axis)
   1920x1080      60.0 +
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 519mm x 324mm
   1920x1200      60.0*+
   3840x1200      60.0  
   2560x1024      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0     59.9  
   720x400        70.1  
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

$ dmesg | grep "drm\|i915"
[    3.331548] [drm] Initialized drm 1.1.0 20060810
[    3.541956] [drm] Memory usable by graphics device = 2048M
[    3.541960] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
[    3.605122] i915 0000:00:02.0: irq 64 for MSI/MSI-X
[    3.605132] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.605133] [drm] Driver supports precise vblank timestamp query.
[    3.939314] fbcon: inteldrmfb (fb0) is primary device
[    4.959278] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    4.959280] i915 0000:00:02.0: registered panic notifier
[    5.314564] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[    5.614409] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[    9.521807] [drm:intel_dp_complete_link_train] *ERROR* failed to train DP, aborting
Comment 13 oss+freedesktop 2014-03-07 17:16:47 UTC
Created attachment 95309 [details]
Xorg.log
Comment 14 frederik 2014-03-08 13:06:17 UTC
Tried to investigate further. The current Displayport 1.2a standard ist only available to members of VESA (which costs 3500$ and more). If anyone here has the DP 1.2a standard document, he may contact me directly and I'll see what I can do. Thanks
Comment 15 Sree Harsha Totakura 2014-03-10 12:56:06 UTC
I see that Intel is a member of VESA (http://www.vesa.org/about-vesa/member-companies/#i).  May be then can provide JohnDoe the document privately.
Comment 16 Jani Nikula 2014-03-11 14:20:35 UTC
(In reply to comment #15)
> I see that Intel is a member of VESA
> (http://www.vesa.org/about-vesa/member-companies/#i).  May be then can
> provide JohnDoe the document privately.

They are personally licensed documents for employees of member companies, so I would not get my hopes up about that.
Comment 17 mb 2014-03-11 22:09:52 UTC
+1 for DP MST on T540P !

Any new infos?
Comment 18 frederik 2014-03-13 09:05:24 UTC
Do not have this document yet...
I shed my hopes on that...
Sorry.
We need to wait for Intel to implement MST.

Any scheduling? 2020? 2025?
Comment 19 Christer Folkesson 2014-03-19 07:11:30 UTC
(In reply to comment #1)
> Hmm, the dock only presents a DP link, so I guess it is acting as a MST hub.
The MST hub has to be in the laptop, for solving the problem it probably don't matter.
There are two versions of the E-series dock. One having a VGA, DVI and DP connector and the other (bigger) having VGA, 2x DVI/DP (marked as VIDEO 1 and VIDEO 2, so you can only choose one connection at a time).

Similar to comment #12 we had a E6410 (~3 year old model) in the same dock (also tried with new dock) and it worked okay, running some Ubuntu 11.04.
This leads me to believe that for the two digital outputs in the dock the Dell E-series docking connector have two distinict DP "cables".
The E7440 ultrabook can, if you connect the displays to the onboard HDMI and mini-DP connector use 3 screens at once (2 external and the built-in). My guess they only could have one more "output" and made a DP MST hub for them internally.





If you guys says it can't be fixed shortly I might suggest to other users with Dell E7x40 laptops a workaround, that some guy on the internet had created (doing a fake xinerama) I reposted and wrote about it in the Linux Mint forum thread I created about this problem, but I myself didn't get it to work (and someone in that thread posted to this bug report, that's how I found it).
See the link github from this post http://forums.linuxmint.com/viewtopic.php?f=59&t=160637&p=827906#p828440
If anyone other gets it to work I would be glad if you wrote in that thread (let this bug report/enhancement be for DP.
Comment 20 Chris Wilson 2014-03-21 10:18:42 UTC
*** Bug 76435 has been marked as a duplicate of this bug. ***
Comment 21 lu8v6hnn4vuk1yqc3lg8 2014-04-15 12:22:33 UTC
+1 for DP MST

T440s+Ultradock
Comment 22 Matthew Thode 2014-04-21 15:29:29 UTC
Here's some more info as well, specific to the pro2x and an e7440u.

DP1 controls all outputs on the pro2x, (DP1/DVI1), (DP2/DVI2), VGA.

Not that I have a vote that counts, but I also vote that this is MST related, though VGA being mirrored as well seems odd to me.
Comment 23 Peter Löffler 2014-04-22 08:46:35 UTC
+1 for DP MST
Comment 24 itayk 2014-04-22 16:58:36 UTC
+1 for DP MST, for Lenovo T440p with Thinkpad Pro Dock.
Comment 25 Danil Valgushev 2014-04-27 14:44:19 UTC
+1 for DP MST, for Dell Latitude E7240
Comment 26 Simon 2014-05-06 09:02:33 UTC
+1 for DP MST (Lenovo T440s, Thinkpad Ultra Dock)
Comment 27 Sree Harsha Totakura 2014-05-06 09:18:31 UTC
Just an update -- Haswell MST is being worked on: http://www.phoronix.com/scan.php?px=MTY4MDI&page=news_item

I can test the patches submitted by David; but it looks like we need to have userspace patches as well in xorg-intel driver.
Comment 28 Leho Kraav (:macmaN :lkraav) 2014-05-19 21:20:47 UTC
While this is being worked on, can anyone confirm that when using the dock, the E7440 built-in HDMI connector still works and can be used for triple monitor?
Comment 29 Boris Petersen 2014-05-20 09:33:13 UTC
(In reply to comment #28)
> While this is being worked on, can anyone confirm that when using the dock,
> the E7440 built-in HDMI connector still works and can be used for triple
> monitor?

Yes I can confirm that works.
Comment 30 tavise 2014-05-28 22:18:42 UTC
+1 Lenovo W540 + UltraDock.
Comment 31 Peter Löffler 2014-05-28 22:37:51 UTC
Sehr geehrte Damen und Herren!

Ich bin vom 21. Mai 2014 bis 30. Mai 2014 im Urlaub.
In dringenden Fällen wenden Sie sich bitte an meine Kollegen unter der Mailadresse: operating@herold.at Ihre Nachricht wird nicht weitergeleitet.


I'm out of office from 21st of may 2014 till 30th of may 2014.
In urgent cases please call our helpdesk: operating@herold.at Your message will not be forwarded

Mit freundlichen Grüßen
with best regards

[http://www.herold.at/images/hbdat_logo.gif]<http://www.herold.at>

HEROLD Business Data GmbH
Guntramsdorfer Straße 105
2340 Mödling

FN 233171z
Landesgericht Wiener Neustadt

Besuchen Sie uns online und mobil www.herold.at!

Weitere Informationen zu unseren Produkten finden Sie unter:
http://ichbinderherold.at
Oder in unserem Video auf YouTube.<http://www.youtube.com/watch?v=i--5-weI7Ck>

[http://www.herold.at/images/fb_icon_mail.gif]<http://www.facebook.at/derherold>Werden Sie Fan von HEROLD auf Facebook!


Diese E-Mail kann vertrauliche und/oder rechtlich geschützte Informationen enthalten. Wenn Sie nicht der richtige Adressat sind oder diese E-Mail irrtümlich erhalten haben, informieren Sie bitte sofort den Absender und vernichten Sie diese E-Mail. Das unerlaubte Kopieren sowie die unbefugte Weitergabe dieser Mail sind nicht gestattet.

This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and delete this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden.
Comment 32 Pavel Sokolov 2014-06-02 15:49:47 UTC
I have the similar situation.
Lenovo X240 + Thinkpad Ultra Dock and I can't split 3840x1080 to 2 * 1920x1080 to support two monitors.
In Windows all work fine.
When this bug will be fixed?
Comment 33 Arik 2014-06-09 21:51:29 UTC
Another +1 
Dell Latitude e7440
Comment 34 Adrian Arturo De Leon Saldivar 2014-06-18 15:39:34 UTC
Same Here: Thinkpad t440s + UltraDock.

Two external monitors connected to the Dock, no mater the combination( VGA + DVI, VGA + HDMI, DIV + HDMI ) it always shows a mirrored image.

(Running Ubuntu Gnome 14.04)
Comment 35 Tim Besard 2014-06-18 15:52:53 UTC
As mentioned above, Dave Airlie is working on this. His WIP tree for MST support, which doesn't seems to have made the 3.16 merge, is publicly available at FDO: http://cgit.freedesktop.org/~airlied/linux/log/?h=drm-i915-mst-support
Tested on a Lenovo T440s + UltraDock and 2 Dell monitors, works decently apart from some momentarily black screens every now and then. YMMV, use at your own risk, etc.
Comment 36 Sree Harsha Totakura 2014-06-18 15:57:32 UTC
(In reply to comment #35)
> http://cgit.freedesktop.org/~airlied/linux/log/?h=drm-i915-mst-support
> Tested on a Lenovo T440s + UltraDock and 2 Dell monitors, works decently
> apart from some momentarily black screens every now and then. YMMV, use at
> your own risk, etc.

I would like to test it too but held myself back as I read somewhere that they require some userspace patches.  Did you patch userspace too? or were they simply enough without any userspace patches?
Comment 37 Tim Besard 2014-06-18 16:02:00 UTC
Works without any modification, userspace driver at v2.99.912 (Arch Linux).
Comment 38 Steffen Weber 2014-06-18 16:07:45 UTC
Seems I have the same issue with an HP EliteBook 840 G1 / HP UltraSlim Dock 2013: https://bugs.freedesktop.org/show_bug.cgi?id=80187
Comment 39 Arik 2014-06-18 16:21:52 UTC
Tim - that's great news.

I would very much be willing to test this work on my setup (Dell Latitude e7440 with Fedora 20) but I'm unfamiliar with kernel building. How would I go about testing this on a fully updated Fedora 20 machine? 

An optimal solution would be an installable rpm of this kernel somewhere (for F20) 

(In reply to comment #37)
> Works without any modification, userspace driver at v2.99.912 (Arch Linux).
Comment 40 Tim Besard 2014-06-18 16:36:03 UTC
Arik: you're in luck, Dave Airlie has a testing repository for Fedora 20 users, see https://airlied.livejournal.com/79657.html
Apparently that repo _does_ contain a patched userspace driver, but it seems to work without as well. Also, the branch that repo is based on (drm-i915-mst-v3.14) lags the branch I tested by some commits.
Comment 41 Steffen Weber 2014-06-18 16:56:44 UTC
David Airlie's "drm-i915-mst-support" branch (http://cgit.freedesktop.org/~airlied/linux/log/?h=drm-i915-mst-support) has solved the problem for me, too!

(HP UltraSlim Dock 2013, xf86-video-intel 2.99.912)
Comment 42 Sree Harsha Totakura 2014-06-21 11:30:47 UTC
I confirm that Airlie's patches work and they require the userspace support added in 2.99.912.  For example, they did not work with 2.99.909.

However, the setup is not yet stable: with 2.99.912, X crashes when I change the orientation of the display; with the current git version of the intel driver, it crashes when I un-dock my notebook (see https://bugs.freedesktop.org/show_bug.cgi?id=80325).
Comment 43 Arik 2014-06-22 14:15:23 UTC
Unfortunately it did not work for me. Possibly the error is on me though since it worked for others here.

I've added David's COPR and installed the kernel, but it did not boot at all. I've even inspected the journal (via journalctl) and there's nothing logged there about the boot - just the subsequent boot (with the older kernel). 

I've looked and noticed that there's also the kernel-modules-extra package and thought that perhaps I need it too, but installing it did not change anything, still the same effect - booting into a black screen (after selected David's kernel in grub). Nothing works - not even CTRL+ALT+F* or other shortcuts.

Mind that I have intel driver 2.21.15.7 and not 2.99* as others seem to have - I can't seem to find a COPR to allow me to install it so that might be the problem? David's COPR contains 2.21.15-6 so it's older. I still tried to downgrade to that one but still the same effect.

Help! :D
Comment 44 Sree Harsha Totakura 2014-06-22 15:01:04 UTC
(In reply to comment #43)
> Mind that I have intel driver 2.21.15.7 and not 2.99* as others seem to have
> - I can't seem to find a COPR to allow me to install it so that might be the
> problem?

It could be that, try compiling the HEAD version from git://anongit.freedesktop.org/xorg/driver/xf86-video-intel.  For the not-so-old 2.99.909 version didn't work but the HEAD version did.

A question to other who got the patches working: do the displays work fine even after un-docking and re-docking (https://bugs.freedesktop.org/show_bug.cgi?id=80355)?
Comment 45 Arik 2014-06-22 19:11:57 UTC
(In reply to comment #44)
> It could be that, try compiling the HEAD version from
> git://anongit.freedesktop.org/xorg/driver/xf86-video-intel.  For the
> not-so-old 2.99.909 version didn't work but the HEAD version did.

I cloned the repository - but how do I build it? 

Running "make" yields:

make: *** No targets specified and no makefile found.  Stop.



Once I upgrade, how do I revert to the version I have now? (in case I'll need to)
Comment 46 Sree Harsha Totakura 2014-06-22 22:00:16 UTC
(In reply to comment #45)
> I cloned the repository - but how do I build it? 
> 
> Running "make" yields:
> 
> make: *** No targets specified and no makefile found.  Stop.
You should first run ./autogen.sh in that directory and then run ./configure

> 
> Once I upgrade, how do I revert to the version I have now? (in case I'll
> need to)
When you run make install, by default the build installs the driver into /usr/local/, so if you keep the build directory unchanged you can later run make uninstall to *downgrade*

Note: if you are new to compiling packages from sources, then I advise you not to try this one.  It is buggy anyway; see https://bugs.freedesktop.org/show_bug.cgi?id=80355.
Comment 47 Jani Nikula 2014-06-23 11:23:10 UTC
*** Bug 80187 has been marked as a duplicate of this bug. ***
Comment 48 Yury 2014-07-13 17:26:01 UTC
I am experiencing a similar problem on a Dell Latitude e7240. 

I am trying to apply the patch according to the manual. But unfortunately I get the following error message: 

"Current kernel version is 3.13.9 ( One Giant Leap for Frogkind)
cannot find patch file: patch-3.13.10".

Can someone tell me what may be wrong? This is the first time I am trying to patch a kernel so please forgive me if my question is stupid.
Comment 49 Jim 2014-07-18 15:13:11 UTC
I have hit this bug on a Dell E7440 laptop, as well.  I'm very interested in a fix as this is preventing the usage of both external monitors.  I've gone back to using Windows, because both monitors work there, and it is painful ;)
Comment 50 awenhaug 2014-07-22 14:07:07 UTC
I have a Latitude 7440 and this guide worked for me: https://01.org/linuxgraphics/node/358

If you follow that link you can see that I also posted the .debs I compiled and installed on my computer, you can use those if you have the balls to do so.
Comment 51 Yury 2014-07-27 10:10:26 UTC
(In reply to comment #50)
> I have a Latitude 7440 and this guide worked for me:
> https://01.org/linuxgraphics/node/358
> 
> If you follow that link you can see that I also posted the .debs I compiled
> and installed on my computer, you can use those if you have the balls to do
> so.

Thank you very much for the link. I will be able to check whether its working on  a E7240 tomorrow (my docking station is at work). 

Anyway, I was able to install this upgrade which is a big step forward for me.

I've had some trouble upgrading to the 2.99.912 userspaces as the link from the manual was not working. I have used this link instead: 
https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa/+build/6171526
Comment 52 Yury 2014-07-28 03:24:57 UTC
It works perfectly for me! Thank you very much for the solution! This is what I call happiness :)
Comment 53 David Lawrence 2014-08-05 14:19:45 UTC
For anyone else trying to set up a multi-monitor docking station:

Dave Airlie's MST code seems to be on track for kernel 3.17.
http://www.phoronix.com/scan.php?page=news_item&px=MTczNzM

Until then, I'm successfully using the drm-next tree with two monitors attached to my T440s ultra dock.
http://cgit.freedesktop.org/~airlied/linux/log/?h=drm-next

Cheers, and thanks to Dave Airlie and everyone else who contributed to this solution!
Comment 54 Peter Löffler 2014-08-05 14:35:49 UTC
Sehr geehrte Damen und Herren!

Ich bin vom 28. Juli 2014 bis 12. August 2014 im Urlaub.
In dringenden Fällen wenden Sie sich bitte an meine Kollegen unter der Mailadresse: operating@herold.at Ihre Nachricht wird nicht weitergeleitet.


I'm out of office from 28st of july 2014 till 12th of august 2014.
In urgent cases please call our helpdesk: operating@herold.at Your message will not be forwarded

Mit freundlichen Grüßen
with best regards

[http://www.herold.at/images/hbdat_logo.gif]<http://www.herold.at>

HEROLD Business Data GmbH
Guntramsdorfer Straße 105
2340 Mödling

FN 233171z
Landesgericht Wiener Neustadt

Besuchen Sie uns online und mobil www.herold.at!

Weitere Informationen zu unseren Produkten finden Sie unter:
http://ichbinderherold.at
Oder in unserem Video auf YouTube.<http://www.youtube.com/watch?v=i--5-weI7Ck>

[http://www.herold.at/images/fb_icon_mail.gif]<http://www.facebook.at/derherold>Werden Sie Fan von HEROLD auf Facebook!


Diese E-Mail kann vertrauliche und/oder rechtlich geschützte Informationen enthalten. Wenn Sie nicht der richtige Adressat sind oder diese E-Mail irrtümlich erhalten haben, informieren Sie bitte sofort den Absender und vernichten Sie diese E-Mail. Das unerlaubte Kopieren sowie die unbefugte Weitergabe dieser Mail sind nicht gestattet.

This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and delete this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden.
Comment 55 Jani Nikula 2014-09-05 11:49:54 UTC
Dave's MST work has landed upstream. Closing this bug as fixed. Thanks for the reports and testing.

Please file *new* bugs for any remaining issues you may encounter with the MST support.
Comment 56 Leho Kraav (:macmaN :lkraav) 2014-09-28 17:07:21 UTC
Confirming fixed. I'm running 3.17.0-rc6 and dual external displays off of E7440 and the small PR03X dock, outputs are now named DP1-1 and DP1-2. Quite glad to not have to manually connect the HDMI cable to the laptop anymore. Dave's the man! xrandr-1.4.1 probably does need some help itself, as I've had it occasionally stall and segfault on me just trying to list these dock-outputs. But that's a topic for another bug.

$ xrandr
Screen 0: minimum 320 x 200, current 3000 x 2160, maximum 8192 x 8192
eDP1 connected primary 1920x1080+0+1080 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080      60.0*+
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
DP1-1 connected 1080x1920+1920+0 right (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080      60.0*+
   1680x1050      59.9  
   1400x1050      59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x800       59.9  
   1152x864       75.0  
   1280x720       60.0  
   1024x768       75.1     60.0  
   832x624        74.6  
   800x600        75.0     60.3     56.2  
   640x480        75.0     60.0  
   720x400        70.1  
DP1-2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080      60.0*+   50.0     59.9  
   1680x1050      59.9  
   1400x1050      59.9  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x800       59.9  
   1152x864       60.0  
   1280x720       60.0     50.0     59.9  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        60.0     59.9  
DP1-3 disconnected (normal left inverted right x axis y axis)
DP1-2-8 disconnected (normal left inverted right x axis y axis)
Comment 57 Peter Löffler 2014-09-29 16:28:01 UTC
Is there any chance for a backport for Redhat 7?
Comment 58 Jani Nikula 2014-09-30 07:04:38 UTC
(In reply to comment #57)
> Is there any chance for a backport for Redhat 7?

You need to ask Red Hat.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.