Bug 73882 - no backlight after suspend to ram with modesetting Trinity [7400G]
Summary: no backlight after suspend to ram with modesetting Trinity [7400G]
Status: RESOLVED DUPLICATE of bug 42960
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.1 (2006.05)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-21 16:09 UTC by D
Modified: 2014-04-04 12:53 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg 3.13 (53.95 KB, text/plain)
2014-01-21 16:09 UTC, D
no flags Details
dmesg-3.13 after hibernation (66.45 KB, text/plain)
2014-01-21 16:42 UTC, D
no flags Details
xorg.log after hibernation (50.52 KB, text/plain)
2014-01-21 16:42 UTC, D
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description D 2014-01-21 16:09:32 UTC
Created attachment 92523 [details]
dmesg 3.13

Everything else is still working, I can type. But there is no backlight. This is without X running at all, kernel 3.13.

I can suspend and resume without modesetting, when I use --quirk-s3-mode and --quirk-s3-bios *together*. I can't properly resume any other way so far (except with fglrx).

Any hints would be very appreciated.

I've tried:

echo 1 > /sys/class/backlight/radeon_bl0/bl_power
echo 1 > /sys/class/backlight/acpi_video0/bl_power
echo 30 > /sys/class/backlight/acpi_video0/brightness
echo 30 > /sys/class/backlight/radeon_bl0/brightness

sleep 5
 vbetool dpms off
 vbetool dpms on

to no avail.
Comment 1 D 2014-01-21 16:41:34 UTC
Hibernation works, though, by the way. I'll attach a dmesg and an xorg.log.
Comment 2 D 2014-01-21 16:42:07 UTC
Created attachment 92525 [details]
dmesg-3.13 after hibernation
Comment 3 D 2014-01-21 16:42:29 UTC
Created attachment 92526 [details]
xorg.log after hibernation
Comment 4 D 2014-01-21 16:52:35 UTC
Oh, and hibernate only works manually via echo disk > /sys/power/state. 

It doesn't work via pm-hibernate - the system doesn't even suspend, but just hangs.
Comment 5 D 2014-01-28 13:48:17 UTC
Updates:
Taking back the last comment, works also with hibernation via pm-hibernate (Ubuntu 12.04).
- Even hibernation only resumes with an active display when booting with kernel parameters nomodeset vga=0. Then I load radeon with modeset=1. (e.g. via modprobe.d)

- freeze > /sys/power/state also does not work.

- radeontool (git) finds some registers are different after resume: (after on top, before in second line)
RADEON_CRTC_H_TOTAL_DISP        0001f478                      | 
RADEON_CRTC_H_TOTAL_DISP        e0003040
RADEON_CRTC_H_SYNC_STRT_WID     060f0001                      | 
RADEON_CRTC_H_SYNC_STRT_WID     00000000
RADEON_CRTC_V_TOTAL_DISP        00000000                        
RADEON_CRTC_V_TOTAL_DISP        00000000
RADEON_CRTC_V_SYNC_STRT_WID     aaaa5555                        
RADEON_CRTC_V_SYNC_STRT_WID     aaaa5555
RADEON_CRTC2_H_TOTAL_DISP       0000000f                      | 
RADEON_CRTC2_H_TOTAL_DISP       0200000f
RADEON_CRTC2_H_SYNC_STRT_WID    00003f3f                      | 
RADEON_CRTC2_H_SYNC_STRT_WID    00000000
RADEON_CRTC2_V_TOTAL_DISP       00000000                      | 
RADEON_CRTC2_V_TOTAL_DISP       00000100

- radeontool light on/off never has any effect on my system.

- avivotool finds that D1CRTC is Disabled after resume.

- There is a warning in dmesg regarding brightness query:
ACPI: No _BQC method, cannot determine initial brightness

- The display is always turned off already during suspend, and simply never returns from there. Hibernation only works, because the BIOS turns the display back on. Without the radeon driver and kms active, as stated above, the quirks help the display of wake up again.
Comment 6 Jose P. 2014-04-04 08:04:39 UTC
Take a look at these bug reports: https://bugs.freedesktop.org/show_bug.cgi?id=43829#c49 and https://bugs.freedesktop.org/show_bug.cgi?id=42960 .
Comment 7 Alex Deucher 2014-04-04 12:53:53 UTC

*** This bug has been marked as a duplicate of bug 42960 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.