Bug 76515 - Activesync folder name support breaks if more than one folder with same name
Summary: Activesync folder name support breaks if more than one folder with same name
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: ActiveSync (show other bugs)
Version: 1.4
Hardware: Other All
: medium minor
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-23 16:58 UTC by Graham Cobb
Modified: 2018-10-13 12:42 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Graham Cobb 2014-03-23 16:58:19 UTC
Testing with outlook.com has shown that it is possible to have two folders with the same name, if they have different types (for example, on outlook.com, the user's calendar and tasks folders have the same name but different collection IDs and different types).

The folder name support in activesync should be enhanced to remember, and check, the folder type when matching the name.

Until this is fixed, the problem can be worked around by using the collection ID instead of the name.  Unfortunately, the user cannot necessarily find out that the problem is happening (because --print-databases can only show the folders for which there are backends handling them -- there is currently no tasks backend, for example).
Comment 1 GitLab Migration User 2018-10-13 12:42:09 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/82.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.