Bug 77082 - linux-image-3.13-1-amd64: discrete video card not available, sometimes hangs on boot
Summary: linux-image-3.13-1-amd64: discrete video card not available, sometimes hangs ...
Status: RESOLVED DUPLICATE of bug 75127
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-05 12:13 UTC by kh3095
Modified: 2014-04-07 21:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg, 3.13.5-1 (75.75 KB, text/plain)
2014-04-05 12:16 UTC, kh3095
no flags Details
dmesg, 3.13.7-1 (71.93 KB, text/plain)
2014-04-05 12:16 UTC, kh3095
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kh3095 2014-04-05 12:13:58 UTC
(duplicate of https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=739992)

Hi,

after installing 3.13.4-1 linux kernel I found out that discrete video card is not available.
During the boot process I experience a long delay at Waiting for /dev to be fully populated
stage and can see something like

pciehp 0000:00:03.0:pcie04: Device 0000:02:00.0 already exists at 0000:02:00, cannot hot-add

After succesful booting lspci doesn't show my discrete video card and xrandr --listproviders
shows only integrated video card.

Sometimes kernel hangs at boot during Waiting for /dev to be fully populated
stage.

With 3.12.9-1 linux kernel everything works OK.

Cheers!
Lev Lamberov


-- Package-specific info:
** Version:
Linux version 3.13-1-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.2 (Debian 4.8.2-14) ) #1 SMP Debian 3.13.4-1 (2014-02-22)

** Command line:
BOOT_IMAGE=/boot/vmlinuz-3.13-1-amd64 root=UUID=1257503e-04c4-40f9-b35e-bdc8ef96c279 ro quiet radeon.audio=1 radeon.dpm=1 nmi_watchdog=0

** Tainted: W (512)
 * Taint on warning.

** Kernel log:
[   20.920652] 		power level 1    sclk: 40000 mclk: 90000 vddc: 1000 vddci: 0
[   20.920653] 		power level 2    sclk: 60000 mclk: 90000 vddc: 1000 vddci: 0
[   20.920654] 	status: r 
[   21.038536] [drm] radeon: finishing device.
[   21.038546] [drm] Disabling audio 0 support
[   21.047750] ------------[ cut here ]------------
[   21.047785] WARNING: CPU: 0 PID: 162 at /build/linux-YhyeNj/linux-3.13.4/drivers/gpu/drm/drm_mm.c:578 ttm_bo_man_takedown+0x29/0x60 [ttm]()
[   21.047789] Memory manager not clean during takedown.
[   21.047793] Modules linked in: snd_hda_codec_hdmi joydev hp_wmi sparse_keymap evdev kvm_amd kvm uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core arc4 rt2800pci rt2800mmio rt2800lib rt2x00pci rt2x00mmio rt2x00lib eeprom_93cx6 mac80211 psmouse serio_raw videodev media edac_mce_amd edac_core snd_hda_codec_idt k10temp cfg80211 rtsx_pci_ms snd_hda_intel snd_hda_codec snd_hwdep btusb bluetooth snd_pcm snd_page_alloc snd_seq snd_seq_device snd_timer snd sp5100_tco i2c_piix4 radeon ttm wmi drm_kms_helper drm hp_accel battery video lis3lv02d soundcore acpi_cpufreq input_polldev i2c_algo_bit processor button ac i2c_core memstick crc_ccitt rfkill shpchp ext4 crc16 mbcache jbd2 sd_mod crct10dif_generic sg sr_mod cdrom crc_t10dif crct10dif_common rtsx_pci_sdmmc mmc_core ehci_pci ahci libahci libata ohci_pci ohci_hcd ehci_hcd xhci_hcd scsi_mod usbcore usb_common thermal thermal_sys rtsx_pci mfd_core r8169 mii
[   21.047907] CPU: 0 PID: 162 Comm: kworker/0:2 Not tainted 3.13-1-amd64 #1 Debian 3.13.4-1
[   21.047912] Hardware name: Hewlett-Packard HP Pavilion dv6 Notebook PC/164B, BIOS F.21 09/13/2011
[   21.047923] Workqueue: pciehp-3 pciehp_power_thread
[   21.047927]  0000000000000009 ffffffff814a08cd ffff880213c95c28 ffffffff8105ba72
[   21.047935]  ffff88021685da40 ffff880213c95c78 ffff880214c4a848 ffff8802141ab300
[   21.047941]  0000000000000000 ffffffff8105bad7 ffffffffa02afb80 ffffffff00000018
[   21.047947] Call Trace:
[   21.047958]  [<ffffffff814a08cd>] ? dump_stack+0x41/0x51
[   21.047966]  [<ffffffff8105ba72>] ? warn_slowpath_common+0x72/0x90
[   21.047972]  [<ffffffff8105bad7>] ? warn_slowpath_fmt+0x47/0x50
[   21.047988]  [<ffffffffa02ca6dc>] ? ttm_bo_force_list_clean+0x3c/0xb0 [ttm]
[   21.048001]  [<ffffffffa02cf6a9>] ? ttm_bo_man_takedown+0x29/0x60 [ttm]
[   21.048042]  [<ffffffffa0353e2a>] ? radeon_ttm_fini+0xaa/0x170 [radeon]
[   21.048077]  [<ffffffffa03547e9>] ? radeon_bo_fini+0x9/0x20 [radeon]
[   21.048121]  [<ffffffffa039cd1a>] ? evergreen_fini+0x9a/0xc0 [radeon]
[   21.048150]  [<ffffffffa0339e31>] ? radeon_device_fini+0x31/0x100 [radeon]
[   21.048181]  [<ffffffffa033bc04>] ? radeon_driver_unload_kms+0x44/0x60 [radeon]
[   21.048201]  [<ffffffffa028af61>] ? drm_dev_unregister+0x21/0xd0 [drm]
[   21.048219]  [<ffffffffa028b042>] ? drm_put_dev+0x32/0x60 [drm]
[   21.048228]  [<ffffffff812a1cde>] ? pci_device_remove+0x2e/0xa0
[   21.048237]  [<ffffffff81354845>] ? __device_release_driver+0x75/0xf0
[   21.048244]  [<ffffffff813548d9>] ? device_release_driver+0x19/0x30
[   21.048250]  [<ffffffff8129c0ad>] ? pci_stop_bus_device+0x8d/0xb0
[   21.048257]  [<ffffffff8129c1c9>] ? pci_stop_and_remove_bus_device+0x9/0x20
[   21.048264]  [<ffffffff812b47d0>] ? pciehp_unconfigure_device+0xa0/0x1a0
[   21.048270]  [<ffffffff812b411b>] ? pciehp_disable_slot+0x5b/0x1f0
[   21.048277]  [<ffffffff812b4329>] ? pciehp_power_thread+0x79/0xe0
[   21.048285]  [<ffffffff81074c2d>] ? process_one_work+0x16d/0x420
[   21.048291]  [<ffffffff810757f6>] ? worker_thread+0x116/0x3b0
[   21.048298]  [<ffffffff810756e0>] ? rescuer_thread+0x330/0x330
[   21.048304]  [<ffffffff8107bae1>] ? kthread+0xc1/0xe0
[   21.048310]  [<ffffffff8107ba20>] ? kthread_create_on_node+0x180/0x180
[   21.048318]  [<ffffffff814ada4c>] ? ret_from_fork+0x7c/0xb0
[   21.048324]  [<ffffffff8107ba20>] ? kthread_create_on_node+0x180/0x180
[   21.048328] ---[ end trace 00e1bbb9390f5a6f ]---
[   21.048337] [drm] radeon: ttm finalized
[   21.048343] vga_switcheroo: disabled
[   29.070286] EXT4-fs (sda1): re-mounted. Opts: (null)
[   29.453793] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   29.705845] device-mapper: uevent: version 1.0.3
[   29.705921] device-mapper: ioctl: 4.27.0-ioctl (2013-10-30) initialised: dm-devel@redhat.com
[   30.390362] fuse init (API version 7.22)
[   30.534018] EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: (null)
[   30.564837] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
[   30.610495] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[   30.682907] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   32.384556] RPC: Registered named UNIX socket transport module.
[   32.384561] RPC: Registered udp transport module.
[   32.384563] RPC: Registered tcp transport module.
[   32.384565] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   32.423563] FS-Cache: Loaded
[   32.456600] FS-Cache: Netfs 'nfs' registered for caching
[   32.529696] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[   35.803310] input: ACPI Virtual Keyboard Device as /devices/virtual/input/input15
[   38.416081] lp: driver loaded but no devices found
[   38.481910] ppdev: user-space parallel port driver
[   52.242219] type=1006 audit(1393267909.903:2): pid=4168 uid=0 old auid=4294967295 new auid=1000 old ses=4294967295 new ses=1 res=1
[   52.308623] switching from power state:
[   52.308636] 	ui class: performance
[   52.308640] 	internal class: none
[   52.308644] 	caps: 
[   52.308648] 	uvd    vclk: 0 dclk: 0
[   52.308653] 		power level 0    sclk: 20000 vddc_index: 2
[   52.308657] 		power level 1    sclk: 50000 vddc_index: 2
[   52.308660] 	status: c 
[   52.308663] switching to power state:
[   52.308665] 	ui class: battery
[   52.308668] 	internal class: none
[   52.308671] 	caps: single_disp 
[   52.308675] 	uvd    vclk: 0 dclk: 0
[   52.308678] 		power level 0    sclk: 20000 vddc_index: 1
[   52.308681] 		power level 1    sclk: 20000 vddc_index: 1
[   52.308683] 	status: r 
[   52.640456] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2860.bin'
[   52.646606] rt2800pci 0000:04:00.0: firmware: direct-loading firmware rt2860.bin
[   52.646621] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.34
[   52.766597] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   58.133682] r8169 0000:03:00.0: firmware: direct-loading firmware rtl_nic/rtl8168e-2.fw
[   58.271368] r8169 0000:03:00.0 eth0: link down
[   58.271429] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   61.917541] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   62.168939] r8169 0000:03:00.0 eth0: link down
[   62.169156] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   62.345352] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   65.925249] wlan0: authenticate with f4:ec:38:a5:7a:18
[   65.939328] wlan0: send auth to f4:ec:38:a5:7a:18 (try 1/3)
[   65.941116] wlan0: authenticated
[   65.943239] wlan0: associate with f4:ec:38:a5:7a:18 (try 1/3)
[   65.946440] wlan0: RX AssocResp from f4:ec:38:a5:7a:18 (capab=0x411 status=0 aid=1)
[   65.946502] wlan0: associated
[   65.946534] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

** Model information
sys_vendor: Hewlett-Packard
product_name: HP Pavilion dv6 Notebook PC
product_version: 0596100000244710000010100
chassis_vendor: Hewlett-Packard
chassis_version: Chassis Version
bios_vendor: Hewlett-Packard
bios_version: F.21
board_vendor: Hewlett-Packard
board_name: 164B
board_version: 06.1F

** Loaded modules:
ctr
ccm
parport_pc
ppdev
lp
parport
binfmt_misc
uinput
nfsd
auth_rpcgss
oid_registry
nfs_acl
nfs
lockd
fscache
sunrpc
fuse
dm_crypt
dm_mod
snd_hda_codec_hdmi
joydev
hp_wmi
sparse_keymap
evdev
kvm_amd
kvm
uvcvideo
videobuf2_vmalloc
videobuf2_memops
videobuf2_core
arc4
rt2800pci
rt2800mmio
rt2800lib
rt2x00pci
rt2x00mmio
rt2x00lib
eeprom_93cx6
mac80211
psmouse
serio_raw
videodev
media
edac_mce_amd
edac_core
snd_hda_codec_idt
k10temp
cfg80211
rtsx_pci_ms
snd_hda_intel
snd_hda_codec
snd_hwdep
btusb
bluetooth
snd_pcm
snd_page_alloc
snd_seq
snd_seq_device
snd_timer
snd
sp5100_tco
i2c_piix4
radeon
ttm
wmi
drm_kms_helper
drm
hp_accel
battery
video
lis3lv02d
soundcore
acpi_cpufreq
input_polldev
i2c_algo_bit
processor
button
ac
i2c_core
memstick
crc_ccitt
rfkill
shpchp
ext4
crc16
mbcache
jbd2
sd_mod
crct10dif_generic
sg
sr_mod
cdrom
crc_t10dif
crct10dif_common
rtsx_pci_sdmmc
mmc_core
ehci_pci
ahci
libahci
libata
ohci_pci
ohci_hcd
ehci_hcd
xhci_hcd
scsi_mod
usbcore
usb_common
thermal
thermal_sys
rtsx_pci
mfd_core
r8169
mii

** Network interface configuration:

auto lo
iface lo inet loopback

** Network status:
*** IP interfaces and addresses:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 68:b5:99:df:af:b0 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 90:00:4e:65:8a:5a brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.101/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever

*** Device statistics:
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
  eth0:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
    lo:   28502     212    0    0    0     0          0         0    28502     212    0    0    0     0       0          0
 wlan0: 2784749    3283    0    0    0     0          0         0   907529    3175    0    0    0     0       0          0

*** Protocol statistics:
Ip:
    3547 total packets received
    0 forwarded
    0 incoming packets discarded
    3545 incoming packets delivered
    3366 requests sent out
    66 dropped because of missing route
Icmp:
    0 ICMP messages received
    0 input ICMP message failed.
    ICMP input histogram:
    0 ICMP messages sent
    0 ICMP messages failed
    ICMP output histogram:
Tcp:
    94 active connections openings
    12 passive connection openings
    25 failed connection attempts
    21 connection resets received
    24 connections established
    3401 segments received
    3155 segments send out
    0 segments retransmited
    0 bad segments received.
    47 resets sent
Udp:
    187 packets received
    0 packets to unknown port received.
    0 packet receive errors
    208 packets sent
UdpLite:
TcpExt:
    18 TCP sockets finished time wait in fast timer
    44 delayed acks sent
    Quick ack mode was activated 7 times
    1961 packet headers predicted
    377 acknowledgments not containing data payload received
    291 predicted acknowledgments
    TCPLossProbes: 2
    TCPLossProbeRecovery: 1
    7 DSACKs sent for old packets
    1 DSACKs received
    20 connections reset due to early user close
    TCPDSACKIgnoredNoUndo: 1
    TCPSackShiftFallback: 1
    TCPRcvCoalesce: 539
    TCPOFOQueue: 140
IpExt:
    InNoRoutes: 2
    InMcastPkts: 18
    OutMcastPkts: 20
    InBcastPkts: 47
    OutBcastPkts: 47
    InOctets: 2776364
    OutOctets: 826336
    InMcastOctets: 3703
    OutMcastOctets: 3783
    InBcastOctets: 6077
    OutBcastOctets: 6077
    InNoECTPkts: 3547


** PCI devices:
00:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] RS880 Host Bridge [1022:9601]
	Subsystem: Advanced Micro Devices, Inc. [AMD] Device [1022:1234]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
	Latency: 0
	Capabilities: <access denied>

00:01.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (int gfx) [1022:9602] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00004000-00004fff
	Memory behind bridge: f0500000-f06fffff
	Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
	Secondary status: 66MHz+ FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>

00:03.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (ext gfx port 1) [1022:960b] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	I/O behind bridge: 00003000-00003fff
	Memory behind bridge: f0400000-f04fffff
	Prefetchable memory behind bridge: 00000000e0000000-00000000efffffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:04.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 0) [1022:9604] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	I/O behind bridge: 00002000-00002fff
	Prefetchable memory behind bridge: 00000000f0000000-00000000f00fffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:05.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 1) [1022:9605] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
	Memory behind bridge: f0300000-f03fffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort+ <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:06.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (PCIE port 2) [1022:9606] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
	Memory behind bridge: f0200000-f02fffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:07.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 3) [1022:9607] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
	Memory behind bridge: f0100000-f01fffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:11.0 SATA controller [0106]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] (prog-if 01 [AHCI 1.0])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 19
	Region 0: I/O ports at 5038 [size=8]
	Region 1: I/O ports at 504c [size=4]
	Region 2: I/O ports at 5030 [size=8]
	Region 3: I/O ports at 5048 [size=4]
	Region 4: I/O ports at 5010 [size=16]
	Region 5: Memory at f070a000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ahci

00:12.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397] (prog-if 10 [OHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at f0709000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci

00:12.2 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396] (prog-if 20 [EHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin B routed to IRQ 17
	Region 0: Memory at f0708000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:13.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397] (prog-if 10 [OHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at f0707000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci

00:13.2 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396] (prog-if 20 [EHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin B routed to IRQ 17
	Region 0: Memory at f0706000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:14.0 SMBus [0c05]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller [1002:4385] (rev 42)
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f0700000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

00:14.3 ISA bridge [0601]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d] (rev 40)
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0

00:14.4 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge [1002:4384] (rev 40) (prog-if 01 [Subtractive decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Bus: primary=00, secondary=07, subordinate=07, sec-latency=64
	Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA- VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-

00:16.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397] (prog-if 10 [OHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at f0705000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci

00:16.2 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396] (prog-if 20 [EHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin B routed to IRQ 17
	Region 0: Memory at f0704000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:18.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration [1022:1200]
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Capabilities: <access denied>

00:18.1 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map [1022:1201]
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:18.2 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller [1022:1202]
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:18.3 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control [1022:1203]
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Capabilities: <access denied>
	Kernel driver in use: k10temp

00:18.4 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control [1022:1204]
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] [1002:9712] (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at 4000 [size=256]
	Region 2: Memory at f0600000 (32-bit, non-prefetchable) [size=64K]
	Region 5: Memory at f0500000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: radeon

01:05.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series] [1002:970f]
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin B routed to IRQ 19
	Region 0: Memory at f0610000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 45
	Region 0: I/O ports at 2000 [size=256]
	Region 2: Memory at f0004000 (64-bit, prefetchable) [size=4K]
	Region 4: Memory at f0000000 (64-bit, prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8169

04:00.0 Network controller [0280]: Ralink corp. RT5390 [802.11 b/g/n 1T1R G-band PCI Express Single Chip] [1814:539f]
	Subsystem: Hewlett-Packard Company Pavilion DM1Z-3000 PCIe wireless card [103c:1637]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort+ <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 17
	Region 0: Memory at f0300000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: rt2800pci

05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader [10ec:5209] (rev 01)
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 46
	Region 0: Memory at f0200000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: rtsx_pci

06:00.0 USB controller [0c03]: NEC Corporation uPD720200 USB 3.0 Host Controller [1033:0194] (rev 04) (prog-if 30 [XHCI])
	Subsystem: Hewlett-Packard Company Device [103c:164b]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 19
	Region 0: Memory at f0100000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd


** USB devices:
Bus 006 Device 002: ID 064e:e258 Suyin Corp. HP TrueVision HD Integrated Webcam
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 003: ID 138a:0018 Validity Sensors, Inc. Fingerprint scanner
Bus 007 Device 002: ID 148f:2000 Ralink Technology, Corp. 
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.13-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages linux-image-3.13-1-amd64 depends on:
ii  debconf [debconf-2.0]                   1.5.52
ii  initramfs-tools [linux-initramfs-tool]  0.115
ii  kmod                                    16-2
ii  linux-base                              3.5
ii  module-init-tools                       16-2

Versions of packages linux-image-3.13-1-amd64 recommends:
ii  firmware-linux-free  3.3

Versions of packages linux-image-3.13-1-amd64 suggests:
ii  debian-kernel-handbook  1.0.15
ii  grub-pc                 2.00-22
ii  linux-doc-3.13          3.13.4-1

Versions of packages linux-image-3.13-1-amd64 is related to:
pn  firmware-atheros        <none>
pn  firmware-bnx2           <none>
pn  firmware-bnx2x          <none>
pn  firmware-brcm80211      <none>
pn  firmware-intelwimax     <none>
pn  firmware-ipw2x00        <none>
pn  firmware-ivtv           <none>
pn  firmware-iwlwifi        <none>
pn  firmware-libertas       <none>
ii  firmware-linux          0.41
ii  firmware-linux-nonfree  0.41
pn  firmware-myricom        <none>
pn  firmware-netxen         <none>
pn  firmware-qlogic         <none>
ii  firmware-ralink         0.41
ii  firmware-realtek        0.41
pn  xen-hypervisor          <none>

-- debconf information:
  linux-image-3.13-1-amd64/postinst/depmod-error-initrd-3.13-1-amd64: false
  linux-image-3.13-1-amd64/prerm/removing-running-kernel-3.13-1-amd64: true
Comment 1 kh3095 2014-04-05 12:14:23 UTC
The problem is still here after update to 3.13.5-1. Logs attached.
Comment 2 kh3095 2014-04-05 12:14:44 UTC
The problem is still here after update to 3.13.7-1. dmesg attached.

I found out that before 3.13.7-1 laptop hangs if radeon.dpm=1 is in grub
configuration, without radeon.dpm=1 laptop boots, but discrete card is
unavailable. After upgrade to 3.13.7-1 I found out that laptop boots both
with and without radeon.dpm=1, but in either case discrete card is still
unavailable.
Comment 3 kh3095 2014-04-05 12:16:08 UTC
Created attachment 96946 [details]
dmesg, 3.13.5-1
Comment 4 kh3095 2014-04-05 12:16:36 UTC
Created attachment 96947 [details]
dmesg, 3.13.7-1
Comment 5 Alex Deucher 2014-04-07 00:56:28 UTC
Does booting with radeon.runpm=0 on the kernel command line in grub fix the issue?
Comment 6 Alex Deucher 2014-04-07 00:59:52 UTC

*** This bug has been marked as a duplicate of bug 75127 ***
Comment 7 kh3095 2014-04-07 21:01:36 UTC
Yes, with radeon.runpm=0 laptop boots without error messages, and discrete card is available. DRI_PRIME works as with linux 3.12.
Comment 8 Alex Deucher 2014-04-07 21:21:24 UTC
Please try the possible fix on bug 75127.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.