Bug 85877 - Requires libsoup-2.4 >=2.42
Summary: Requires libsoup-2.4 >=2.42
Alias: None
Product: GeoClue
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Geoclue Bugs
QA Contact: Geoclue Bugs
Depends on:
Reported: 2014-11-04 22:29 UTC by Gilles Dartiguelongue
Modified: 2014-11-12 17:59 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description Gilles Dartiguelongue 2014-11-04 22:29:42 UTC
We received a bug report at Gentoo that geoclue would not build due to implicit declaration of soup_session_new. This symbol appeared in libsoup-2.42 and is used since geoclue-2.0 it seems.

Please add required version check to configure.

$ git grep "soup_session_new"
src/gclue-web-source.c:        priv->soup_session = soup_session_new_with_options
src/geocode-glib/geocode-forward.c:        forward->priv->soup_session = soup_session_new ();
src/geocode-glib/geocode-reverse.c:        object->priv->soup_session = soup_session_new ();
Comment 1 Zeeshan Ali 2014-11-12 17:59:18 UTC
commit: 8d535cd 8d535cdc7ffe93a769412932d3603673efca5627
Author: Zeeshan Ali (Khattak) <zeeshanak@gnome.org>
Date:   Wed Nov 12 17:56:41 2014 +0000

    Require libsoup >= 2.42
    We use API that was introduce in this version so lets explicitly require
    this particular version.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.