Bug 86102 - Activesyncd creates wrong RRULE for nth recurrence
Summary: Activesyncd creates wrong RRULE for nth recurrence
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: ActiveSync (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: SyncEvolution Community
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 70693
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-10 10:41 UTC by Graham Cobb
Modified: 2018-10-13 12:42 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Patch to handle WeekOfMonth (4.97 KB, patch)
2014-11-11 20:59 UTC, Graham Cobb
Details | Splinter Review

Description Graham Cobb 2014-11-10 10:41:52 UTC
See also bug #70693

Activesyncd is losing the "nth" attribute for monthly repeating BYDAY events.

The following EAS data:

            <Recurrence xmlns="Calendar:">
              <Recurrence_Type>3</Recurrence_Type>
              <Recurrence_Interval>1</Recurrence_Interval>
              <Recurrence_WeekOfMonth>1</Recurrence_WeekOfMonth>
              <Recurrence_DayOfWeek>16</Recurrence_DayOfWeek>
            </Recurrence>

is turned into the following RRULE:

RRULE:FREQ=MONTHLY;BYDAY=TH

which should be:

RRULE:FREQ=MONTHLY;BYDAY=1TH

This is obviously related to bug #70693.  Until I investigate further, I don't know if this is caused by the same underlying problem as that bug, is a deliberate attempt to avoid triggering that bug or is a separate bug.  Even if this is separate, bug #70693 may still prevent the corrected event from being synchronised.

As events with recurrence like "first Monday of the month" are very common, it would be nice to fix this.
Comment 1 Graham Cobb 2014-11-11 20:59:11 UTC
Created attachment 109307 [details] [review]
Patch to handle WeekOfMonth

This patch makes activesyncd handle the EAS <WeekOfMonth> tag and produce the correct RRULE.  Checked using logging.

Of course, bug #70693 still means that the recurrence gets corrupted later, but at least this should work when that bug is fixed.
Comment 2 GitLab Migration User 2018-10-13 12:42:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/88.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.