Bug 87144 - Contacts are being treated as updated and written to database, but their content did not change
Summary: Contacts are being treated as updated and written to database, but their cont...
Status: RESOLVED MOVED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: 1.3.99.3
Hardware: Other All
: medium normal
Assignee: Patrick Ohly
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 08:56 UTC by Mateusz Polrola
Modified: 2018-10-13 12:42 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Logs of 1st and 2nd synchronization (289.28 KB, text/plain)
2014-12-09 08:57 UTC, Mateusz Polrola
Details
Example vcard that is causing issue (65 bytes, text/plain)
2014-12-09 08:58 UTC, Mateusz Polrola
Details
Proposed patch (1.12 KB, patch)
2014-12-10 10:56 UTC, Mateusz Polrola
Details | Splinter Review

Description Mateusz Polrola 2014-12-09 08:56:06 UTC
When using version 1.3.99.5, contacts that does not have any given or family name assigned but contains only email address are being updated with each synchronization, but their content did not change since last synchronization.

This may be similar to bug 84710, but cause of that one was introduced already to 1.4.99.4 version.
Comment 1 Mateusz Polrola 2014-12-09 08:57:32 UTC
Created attachment 110610 [details]
Logs of 1st and 2nd synchronization
Comment 2 Mateusz Polrola 2014-12-09 08:58:02 UTC
Created attachment 110611 [details]
Example vcard that is causing issue
Comment 3 Mateusz Polrola 2014-12-09 09:17:39 UTC
This issue is not happening with 1.4.99.4.
Comment 4 Mateusz Polrola 2014-12-10 10:56:49 UTC
Created attachment 110678 [details] [review]
Proposed patch

Issue is caused by using TEL or EMAIL fields as a fallback for NAME field.
In that case FN field is left empty, but EDS is detecting that and it is generating FN based on NAME field when contact is added to database.
This patch ensures that when falling back to use TEL or EMAIL as a NAME, FN will be also set.
Comment 5 Patrick Ohly 2014-12-12 09:44:48 UTC
Patch looks good. Before merging it I want to add a test case and check why this was not causing problems in the stable release of SyncEvolution.
Comment 6 GitLab Migration User 2018-10-13 12:42:59 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/SyncEvolution/syncevolution/issues/95.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.