Bug 87771 - [NV63] X freezes after login
Summary: [NV63] X freezes after login
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-27 19:11 UTC by Vivek
Modified: 2015-01-01 09:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Kernel messages from netconsole (5.93 KB, text/plain)
2014-12-27 19:11 UTC, Vivek
no flags Details
Xorg log (21.79 KB, text/plain)
2014-12-27 19:12 UTC, Vivek
no flags Details
Xorg log after logging in (44.46 KB, text/plain)
2014-12-28 05:04 UTC, Vivek
no flags Details
Netconsole log (5.14 KB, text/plain)
2014-12-28 05:07 UTC, Vivek
no flags Details
Netconsole log (1.50 KB, text/plain)
2014-12-28 05:33 UTC, Vivek
no flags Details
dmesg (61.31 KB, text/plain)
2014-12-29 04:31 UTC, Vivek
no flags Details
Xorg log (30.14 KB, text/plain)
2014-12-29 04:36 UTC, Vivek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vivek 2014-12-27 19:11:23 UTC
Created attachment 111404 [details]
Kernel messages from netconsole

After login attempt the screen freezes completely and even the mouse doesn't move. 

On login the screen freezes completely and I cant even ssh into the machine. The only option then is to press the reset button. Since the system freezes on login I could get the kernel messages only by using netconsole. It occurs every time.
Comment 1 Vivek 2014-12-27 19:12:22 UTC
Created attachment 111405 [details]
Xorg log
Comment 2 Vivek 2014-12-27 19:15:39 UTC
I forgot to mention that my machine is an old machine with Nvidia 7050.
Comment 3 Ilia Mirkin 2014-12-27 19:16:50 UTC
Hmmm...

[     5.710] (EE) [drm] KMS not enabled
[     5.710] (EE) open /dev/dri/card0: No such file or directory

You need to look into that -- is /dev/dri/card0 really not there, or are the permissions just messed up (e.g. you're trying to run X as non-root and not in the right group). This means that nouveau isn't really being used by X.

Separately, we've recently disabled MSI on all nv4x IGP's -- it was just causing too much trouble for too little gain. Try booting with

nouveau.config=NvMSI=0
Comment 4 Vivek 2014-12-28 04:52:22 UTC
I'm sorry, that Xorg log I attached before is the log which I got after booting with nomodeset as the kernel parameter, because that is the only way I can login. Otherwise the system completely freezes after login so there is no way for me to retrieve the Xorg log.
Comment 5 Vivek 2014-12-28 05:04:19 UTC
Created attachment 111416 [details]
Xorg log after logging in

Strangely I could login once and before it hanged I collected the Xorg log.
Comment 6 Vivek 2014-12-28 05:07:42 UTC
Created attachment 111417 [details]
Netconsole log

This is the netconsole log when I could login and it didn't hang for a while.
Comment 7 Vivek 2014-12-28 05:33:52 UTC
Created attachment 111418 [details]
Netconsole log

I booted with the parameter nouveau.config=NvMSI=0 
Now I am not even getting to the login screen. The screen freezes showing:


[    3.104591] nouveau  [     CLK][0000:00:10.0] --: core 24 MHz  
[    3.110538] [TTM] Zone  kernel: Available graphics memory: 1409596 kiB
[    3.110623] [TTM] Initializing pool allocator
[    3.110693] [TTM] Initializing DMA pool allocator
[    3.110776] nouveau  [     DRM] VRAM: 253 MiB
[    3.110840] nouveau  [     DRM] GART: 512 MiB
[    3.110908] nouveau  [     DRM] TMDS table version 1.1
[    3.110971] nouveau W[     DRM] TMDS table script pointers not stubbed
[    3.111040] nouveau  [     DRM] DCB version 3.0
[    3.111103] nouveau  [     DRM] DCB outp 00: 01000110 00000023
[    3.112925] nouveau  [     DRM] DCB conn 00: 0000
[    3.113040] nouveau  [     DRM] DCB conn 01: 1161
[    3.113156] nouveau W[     DRM] Pointer to flat panel table invalid
[    3.113537] nouveau  [     DRM] Saving VGA fonts
[    3.150665] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.150748] [drm] Driver supports precise vblank timestamp query.
[    3.152664] nouveau  [     DRM] MM: using M2MF for buffer copies
[    3.161916] systemd-logind[773]: Watching system buttons on /dev/input/event1 (Power Button)
Comment 8 Marcin Slusarz 2014-12-28 10:55:47 UTC
Any change if you boot with nouveau.config=PMPEG=0 ?
Comment 9 Vivek 2014-12-28 11:24:27 UTC
I tried it the first time and it hanged even before I could get to the login screen. But the second time I could login and it didn't freeze and it worked fine. I tried it again and it again hanged before login screen appeared.
Comment 10 Vivek 2014-12-29 04:31:44 UTC
Created attachment 111448 [details]
dmesg

It did hang with nouveau.config=PMPEG=0 but this time I could ssh and get the dmesg and Xorg log.
Comment 11 Vivek 2014-12-29 04:36:50 UTC
Created attachment 111449 [details]
Xorg log

Xorg log after booting with nouveau.config=PMPEG=0
Comment 12 Vivek 2015-01-01 09:24:05 UTC
I am able to switch to a virtual terminal using Ctrl+Alt+F1. So (I think) KMS is working.

Any help?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.