Bug 89042 - accountsservice >0.37 breaks with multiple usernames for a single uid
Summary: accountsservice >0.37 breaks with multiple usernames for a single uid
Status: RESOLVED FIXED
Alias: None
Product: accountsservice
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium major
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
: 93775 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-09 15:28 UTC by Andrea Ratto
Modified: 2017-12-19 21:05 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Andrea Ratto 2015-02-09 15:28:42 UTC
I have a second username tied to my account, sharing the same user id, so that
I can log in with a second password (which does not unlock some encrypted stuff
automatically).

This has worked fine until accountsservice-0.37. After that it broke and GDM
would not show up anymore.

AFAIK multiple username/password for the same user id are legal and they should
not confuse accountsservice.
Comment 1 Robert Ancell 2017-12-19 20:47:33 UTC
*** Bug 93775 has been marked as a duplicate of this bug. ***
Comment 2 Ray Strode [halfline] 2017-12-19 21:05:40 UTC
I don't have a reference handy, but this got fixed at some point.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.