Bug 90382 - mouse pointer is not visible when run weston-launch
Summary: mouse pointer is not visible when run weston-launch
Status: RESOLVED MOVED
Alias: None
Product: Wayland
Classification: Unclassified
Component: weston (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-09 17:23 UTC by tadeusz.okuljar
Modified: 2018-06-08 23:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
weston log (21.90 KB, text/plain)
2015-05-09 17:23 UTC, tadeusz.okuljar
Details
working weston log (7.88 KB, text/plain)
2015-05-11 20:26 UTC, tadeusz.okuljar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tadeusz.okuljar 2015-05-09 17:23:49 UTC
Created attachment 115659 [details]
weston log

I use UBuntu 14.04 LTS. When I run ./weston-launch -- --log=westonLog1.txt from tty2 weston starts (a wallpaper and a top bar is visible) but mouse pointer is not visible.
Comment 1 Pekka Paalanen 2015-05-11 06:17:04 UTC
GL-renderer on DRM-backend with Mesa softpipe... I didn't expect that to even start at all.

Seems like two options here:
- see if Weston is missing any failure checks in the DRM/GBM/EGL init paths
- see what Mesa is doing with softpipe on EGL GBM platform, should it even work at all, and if it should, how to fix it

When I look at your log, I think you should be missing all graphics, not just the cursor. Is that not the case?

If you just want to run with software rendering, you'd better use Pixman renderer: --use-pixman. It should be much faster than softpipe, and I think it should be faster than llvmpipe, too.
Comment 2 Pekka Paalanen 2015-05-11 06:19:35 UTC
I am kind of puzzled why you do get the wallpaper visible...

What drivers are you using exactly with the kernel? An unfiltered kernel log would be nice.
Comment 3 tadeusz.okuljar 2015-05-11 19:59:23 UTC
In details it looks like this:

I run weston-launch from tty2 - first I get some artifacts - only part of the screen is redrawn and then I get a black screen but when I move a mouse a wallpaper and a top bar is visible ( without a mouse pointer ). 

My PC is is equipped with Geforce GTX 970. Weston doesn't work with Nvidia proprietary drivers so I switched to Nouveau driver but unfortunately that driver doesn't support hardware acceleration for Geforce 900 series, glxinfo | grep OpenGL returns:

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)
OpenGL version string: 3.0 Mesa 10.6.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

Have you already test Weston on Geforce 900 series ? I think that you can reproduce that behaviour which is connected with a software rendering.

I build weston again on my laptop which is equipped with Nvidia Quadro K1000M. Nouveau driver supports hardware acceleration for that card, glxinfo | grep OpenGL: 

OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NVE7
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.6.0-devel
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.6.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

When I run weston-launch on my laptop everything works fine, mouse pointer is visible, I can launch weston-terminal and weston flower from a top bar. I attached a log from working configuration. It contains following line: 

warning: EGL_EXT_swap_buffers_with_damage not supported. Performance could be affected

Could you describe that issue ?
Comment 4 tadeusz.okuljar 2015-05-11 20:02:54 UTC
In details it looks like this:

I run weston-launch from tty2 - first I get some artifacts - only part of the screen is redrawn and then I get a black screen but when I move a mouse a wallpaper and a top bar is visible ( without a mouse pointer ). 

My PC is equipped with Geforce GTX 970. Weston doesn't work with Nvidia proprietary drivers so I switched to Nouveau driver but unfortunately that driver doesn't support hardware acceleration for Geforce 900 series, glxinfo | grep OpenGL returns:

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)
OpenGL version string: 3.0 Mesa 10.6.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

Have you already test Weston on Geforce 900 series ? I think that you can reproduce that behaviour which is connected with a software rendering.

I built weston again on my laptop which is equipped with Nvidia Quadro K1000M. Nouveau driver supports hardware acceleration for that card, glxinfo | grep OpenGL: 

OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NVE7
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.6.0-devel
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.6.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

When I run weston-launch on my laptop everything works fine, mouse pointer is visible, I can launch weston-terminal and weston flower from a top bar. I attached a log from working configuration. It contains following line: 

warning: EGL_EXT_swap_buffers_with_damage not supported. Performance could be affected

Could you describe that issue ?
Comment 5 tadeusz.okuljar 2015-05-11 20:23:03 UTC
In conclusion, Nouveau drivers even when supports hardware acceleration provides significantly worse performance compare to Nvidia proprietary drivers. I will make some tests and send you my results. 

I have following nouveau packages for Ubuntu 14.04 LTS:

xserver-xorg-video-nouveau: 1:1.0.11+git20141030.3fb97d78-0ubuntu0sarvatt~trusty2
Comment 6 tadeusz.okuljar 2015-05-11 20:26:16 UTC
Created attachment 115701 [details]
working weston log
Comment 7 Pekka Paalanen 2015-05-12 06:52:53 UTC
Finding someone who is interested in fixing software-GL on GBM/KMS might take a while unless you can prove it's a Nouveau bug.

You have provided the versions of Mesa and the Nouveau Xorg driver (which is completely irrelevant and not used here). What is the kernel version where you got the Nouveau kernel driver from? Also I'd expect Ubuntu to patch its kernels, so that's an additional uncertainty in the kernel driver version.

(In reply to tadeusz.okuljar from comment #5)
> In conclusion, Nouveau drivers even when supports hardware acceleration
> provides significantly worse performance compare to Nvidia proprietary
> drivers. I will make some tests and send you my results. 

Nouveau is obviously going to be slow, if your GPU is running at a clock speed that is a fraction of what the proprietary driver uses. But that's off-topic here.

(In reply to tadeusz.okuljar from comment #3)
> When I run weston-launch on my laptop everything works fine, mouse pointer
> is visible, I can launch weston-terminal and weston flower from a top bar. I
> attached a log from working configuration. It contains following line: 
> 
> warning: EGL_EXT_swap_buffers_with_damage not supported. Performance could
> be affected
> 
> Could you describe that issue ?

Nothing to worry about. It only means a small bit of optimization in screen updates is not available. I'm not sure that even has any effect on the DRM backend.
Comment 8 tadeusz.okuljar 2015-05-12 21:12:25 UTC
You are right. When I run weston it links to libs which I built as weston dependencies - for nouveau: libdrm_nouveau.so.2.0.0 and nouveau_dri.so My kernel version that's 4.0.0-040000-generic. I built libs mentioned here: http://wayland.freedesktop.org/ubuntu12.04.html
Comment 9 GitLab Migration User 2018-06-08 23:53:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/wayland/weston/issues/65.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.