Bug 90484 - LLVM >=r237140 causes gpu lockups Spec Ops: The Line
Summary: LLVM >=r237140 causes gpu lockups Spec Ops: The Line
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
Depends on:
Reported: 2015-05-16 16:14 UTC by Arek Ruśniak
Modified: 2015-07-31 09:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

dmesg (145.40 KB, text/plain)
2015-05-16 16:14 UTC, Arek Ruśniak

Description Arek Ruśniak 2015-05-16 16:14:06 UTC
Created attachment 115840 [details]

I can't even start gameplay, gpu lockups a few seconds after intro in game menu. cape verde

first bad combo:
llvm >=r237140 + mesa git 

llvm r237139 (or 3.6) + mesa git works really good.
Comment 1 Sylvain BERTRAND 2015-05-16 18:51:20 UTC
I'm curious about your setup: are dota2/portal2 (source engine games) rendered without glitches with your setup?
Do you enable llvm multi-threading? Do you enable mesa shader cache?
Comment 2 Arek Ruśniak 2015-05-16 21:03:39 UTC
@Sylvain, i didn't know about llvm-MT so probably i don't use this stuff. 
IIRC shader cache is enable by default in mesa. So yes, i use this by default :)
I don't have dota2/portal but i've just check out tf2, left4dead2 & hl2loascoast - not much but yes, sometimes i see somethings strange in rendering. But this is different story than this lockup for Ops.
Comment 3 Michel Dänzer 2015-05-18 03:14:07 UTC
Please run the game with the environment variable R600_DEBUG=vs,gs,ps and attach the stderr output corresponding to the good and bad case.
Comment 4 Sylvain BERTRAND 2015-05-18 13:52:00 UTC
Since you are on PITCAIRN, give a try with R600_DEBUG=switch_on_eop
Comment 5 Arek Ruśniak 2015-05-18 16:08:10 UTC
It's complicated a little bit more than i thought.
r237139 is affected too, but need more time(about 100-120 sec)to trigger, this is why i didn't see it before. Now i've tried r230876 and time to trigger ~ 11 min. And a really dunno what interval should i take. 

But still trying.

Sylvain i will try it and give feedback to you. (and i have Cape Verde XT (hd7770), I should buy Pitcairn but i was to stingy:)
Comment 6 Michel Dänzer 2015-05-19 01:00:43 UTC
(In reply to Arek Ruśniak from comment #5)
> r237139 is affected too, but need more time(about 100-120 sec)to trigger,
> this is why i didn't see it before. Now i've tried r230876 and time to
> trigger ~ 11 min.

The hangs before r237140 might simply be random, and might have been there for a long time if not forever. See e.g. bug 90481.
Comment 7 Arek Ruśniak 2015-05-19 07:44:24 UTC
Yes I saw #90481 before filled this. It's doesn't look the same. I don't even touch gameplay. In my case all lockups is happening in game menu. When I able to start the game i can play over 40 min. But i am not hard player so hard to tell it is never happen. Maybe fortune is by my side.

Yesterday i tried r228821 and it works over 50min without issues, so i think it is somewhere in 3.7 branch. If i don't screw up it shoud be between r228821 & r230067. 
Keep searching. 

PS. I have another issue with blinking fog in MetroLL (in game, in "waiting screen", and in intro) and it's the same: somewhere between r228821 & r230067, so i'll find the little bastard for sure (but it's probably another bug)
Comment 8 Arek Ruśniak 2015-07-31 09:26:04 UTC
I don't know when and how but it's no longer exist. So i will close this one.
I've tested it few weeks ago and everything works good by several hours (menu/gameplay). 
btw sorry for delay. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.