Bug 9050 - X won't start with Vesa driver and Trident CyberBlade XP4m32
Summary: X won't start with Vesa driver and Trident CyberBlade XP4m32
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Vesa (show other bugs)
Version: 7.1 (2006.05)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-16 03:25 UTC by David Sterratt
Modified: 2008-10-14 15:38 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description David Sterratt 2006-11-16 03:25:07 UTC
I've entered this bug in the Ubuntu bugzilla already
(https://launchpad.net/bugs/68814) 
but am getting desperate to fix the problem so am entering it here too.

When I try to start the xserver using the vesa driver on my toshiba R100 with
Trident CyberBlade XP4m32 graphics card, X takes up 100% of the CPU. The last
entry in Xorg.0.log is:

(II) VESA(0): Splitting WC range: base: 0xffffffff, size: 0x2000000

The logs and the lspci output are attached to the ubuntu bug.

I've searched google, and the xorg bugzilla extensively, but not found anything
similar.

The vesa driver does appear to work on Fedora core 6 (with the same version of
X: 7.1.1), so perhaps this is an issue with Ubuntu's packaging or upgrade
procedure. Still, I feel that X should give a meaningful error and abort rather
than hanging partway through.

Any suggestions about what to try would be much appreciated.
Comment 1 Daniel Stone 2007-02-27 01:34:41 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 2 Markus Kuhn 2007-08-10 10:59:25 UTC
I can confirm that the exact same bug occurs with the same laptop also under openSUSE 10.2 (X11 Version 7.1.99.902 (7.2.0 RC 2)); further details filed on the SUSE bug tracker:
https://bugzilla.novell.com/show_bug.cgi?id=248775
Comment 3 David Sterratt 2008-10-14 15:38:09 UTC
This no longer seems to be an issue for the version of xorg that ships with Ubuntu Hardy:
X.Org X Server 1.4.0.90


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.